Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Triton Sand Filter - pump stopped working

  1. Back To Top    #1

    Join Date
    Jul 2016
    Location
    Gainesville
    Posts
    4

    Triton Sand Filter - pump stopped working

    Hi, I have a 21,000 Gal, Marcite/Granite Pool. I am a new pool owner and am still trying to become familiar with the ins and outs of pool care. We left on vacation for 2 weeks and had someone care for our pool, but on our return when I try to turn the pump on, it runs dry. I have refilled it with water and usually hitting the reset button works, but not this time. I also tried letting air out by the air release valve on our Triton Sand Pump and when water starts to run I close the valve and start it again. I did this three times, each time I let the air out, it took about 5 - 10 min. for water to start running through the valve. Could it be possible that I did not let all the air out and should have let it run through longer? Any help is appreciated. Have a great day!
    Happy Swimmer
    21000 Gallons - Marcite/Granite Pool
    Florida

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,201

    Re: Triton Sand Filter - pump stopped working

    Hi, welcome to TFP! Could you post a picture of your equipment pad and any valves you have on the plumbing lines? That could help us troubleshoot your problem.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3

    Join Date
    Jul 2016
    Location
    Gainesville
    Posts
    4

    Re: Triton Sand Filter - pump stopped working

    Here are a few pictures, let me know if there is anything else you need. Hope pics go through okay. Thanks for your help.
    IMG_0432.jpgIMG_0433.jpgIMG_0434.jpg
    Happy Swimmer
    21000 Gallons - Marcite/Granite Pool
    Florida

  4. Back To Top    #4
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,201

    Re: Triton Sand Filter - pump stopped working

    How high is the water level in your pool? If I understand correctly, the pump doesn't stay primed and you get a lot of air in the pump pot?
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  5. Back To Top    #5

    Join Date
    Jul 2016
    Location
    Gainesville
    Posts
    4

    Re: Triton Sand Filter - pump stopped working

    Water level is high, about 1/2 inch under the top of the tile that goes around the pool. When I turn it on there is a tiny amount of water that runs out, but then the water stops flowing completely. Could there be a clog I can't see or something?
    Last edited by PoolIssues123; 07-19-2016 at 09:46 AM. Reason: Adding additional info
    Happy Swimmer
    21000 Gallons - Marcite/Granite Pool
    Florida

  6. Back To Top    #6
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Triton Sand Filter - pump stopped working

    Have you put a hose in the pump basket to fill it up before trying to prime the pump?

    Either there is a clog or a valve stopping the water flow to the pump. Or, more likely, a suction leak that is sucking air into the pump. More here about tracking down a suction leak, Pool School - Suction Side Air Leaks
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  7. Back To Top    #7

    Join Date
    Jul 2016
    Location
    Gainesville
    Posts
    4

    Re: Triton Sand Filter - pump stopped working

    Tks for all your help. i did finally figure out the issue. The o-ring was off the strainer lid. I put it back on and let the air out quite a few more times and that was all it needed. Glad it was an easier fix than I thought. This is a wonderful site and I'm sure I will learn everything I need to know when it comes to maintaining my pool.

    Thanks again,
    Happy Swimmer
    21000 Gallons - Marcite/Granite Pool
    Florida

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •