Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: can't get rid of algae

  1. Back To Top    #1

    Join Date
    Jul 2016
    ontario canada

    can't get rid of algae

    Hi everybody,

    Since I have opened the pool, the water has not been clear because there was some sand at the bottom of pool. The problem was our sand filter, we got it repaired. Then we had algae. We can't get rid of the algae. The water is very very clear and very blue. At the bottom, deeper end, we have a lot of dead algae. At the other end, I think it is dead, not sure, it is yellow, brown. I shocked it a lot. 30 liters of clorine on Sunday and 40 last night (Tuesday), using the Algesize. Still the same color... when I vacuumed it, it went straight back into the pool. I could see it a yellowish color through the filter. What can I do? the clorin does nothing....
    my pool is 20 by 40

  2. Back To Top    #2
    cj3737's Avatar
    Join Date
    Jun 2016
    North Ogden, UT

    Re: can't get rid of algae

    What kind of filter are you using?
    What was the repair on the filter?
    What is your pool made of? Plaster/vinyl?
    Are you using straight bleach or just the algaecide?

    What kind of test kit do you have?
    Inherited 24' Muskin Above ground
    13500 gal
    Hayward S180T92S Sand filter
    Taylor K-2006C Speedstir
    TFPC for Beginners | Pool Math | Pool School | CYA Chart | SLAM | Test Kits | ABC's

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts