Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Filter shooting dirty water back into pool after about 15 seconds of running cleaner

  1. Back To Top    #1

    Join Date
    Jul 2016
    Location
    Lincoln, Nebraska
    Posts
    6

    Filter shooting dirty water back into pool after about 15 seconds of running cleaner

    Hi! First post for me here on TFP. So I had an algae bloom and am coming back from it. Killed it all and it all settled out to the bottom. Now working on vacuuming it up with the dirt devil pool cleaner. However, after I have it running for about 15 seconds, the return jets start blasting dirty water back into the pool. Seems the algae getting vacuumed up is just going right thru the filter instead of getting caught. I then backwash, rinse, and start again and the same thing happens? Read a few other posts, so I'm going to take a peek inside the sand filter. Any help is welcomed! Thanks!

    Oh oh I have a 24' diameter 12,500 gallon pool.

  2. Back To Top    #2

    Join Date
    Jul 2016
    Location
    Lincoln, Nebraska
    Posts
    6

    Re: Filter shooting dirty water back into pool after about 15 seconds of running clea

    Took apart the sand filter and pulled out the laterals. No visible cracks, sand looked fine aside from some small chunks that had hair in them. Spose those could have clogged the filter a bit, but I wouldn't think too much. Any ideas guys? Should I put the sand back in and try it, or should I get that zeo-sand stuff?

  3. Back To Top    #3
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Filter shooting dirty water back into pool after about 15 seconds of running clea

    Welcome to TFP!

    Most people don't seem to like zeolite, but some folks love it. I would use sand and there is no need to replace it. There is a link to deep clean in this page, Pool School - Maintenance and Cleaning of Pool Filters, maybe something there will help.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •