Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: IC20 high salt flashing

  1. Back To Top    #1

    IC20 high salt flashing

    My IC20 started flashing green indicating high salt. I tested it a few times and my salt level is approximately 3000ppm. I cleaned the cell and it still flashes. I've searched and can't seem to find any info on this. My CYA is 70, FC is 2-4ppm and PH 7.6.

    When I turn on the cell the green light flashes rapidly (it used to alternate green and red but I'm wondering if the red LED died) for a few minutes and then changes to flashing slowly. Is there some other thing that could cause the sensor to read high salt? Do I need to call the pool builder and get it serviced?

  2. Back To Top    #2

    Re: IC20 height salt flashing

    What is the water temperature?

    Do you have automation (EasyTouch or IntelliTouch)?

    How are you testing for salinity?

    How old is the cell?

  3. Back To Top    #3

    Re: IC20 height salt flashing

    Water temp is 86. No automation. I use the K-1766 kit to test salt level. The cell is about 4 years old.

  4. Back To Top    #4

    Re: IC20 high salt flashing

    Possibly a bad temperature sensor. The flow switch is a combination flow switch with a temperature sensor inside. If the temperature sensor is giving a lower than actual salt, that could do it.

    Also, sometimes water gets under the control panel and shorts out the electronics.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts