Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Caretaker leaking at valve

  1. Back To Top    #1

    Join Date
    May 2016
    Location
    Las Vegas, NV
    Posts
    7

    Caretaker leaking at valve

    Put in a new rebuild kit for my caretaker. Took care to have all o rings/gaskets in place. It leaks from where the two halves of the dome comes together. Any ideas?
    Pool built in 1999 23,000 gallons, 2 hp Pentair Whisperflow, Clean and Clear 520, Caretaker 99, Fiberstars 6008 Ultra Pure ozonator

  2. Back To Top    #2

    TFP Guide


    Join Date
    Feb 2015
    Location
    Chandler AZ
    Posts
    744

    Re: Caretaker leaking at valve

    Did you thoroughly clean the mating surfaces - especially where the o-ring sits? How about the outside area where the band clamp sits and the band clamp itself? Did you lube the o-ring that seals the two pieces?

    Put a little silicone spray or WD 40 on the threads and nut of the band clamp to make tightening a little easier. As you are tightening, lightly tap around the band clamp to help it seat better.
    Gene
    ​12,300 gal IG play pool - Pebbletec - built 10/1999 || Hayward S360SX 36" sand filter || Hayward Ecostar SP3400 VSP || A&A In-Floor cleaning system || Quik Water Leveler || Quik Dek-clor (limited use)
    TF-100 testkit / Speedstir - A good test kit is not an expense, it's an investment

  3. Back To Top    #3

    Join Date
    May 2016
    Location
    Las Vegas, NV
    Posts
    7

    Re: Caretaker leaking at valve

    I will try a more thorough cleaning. I did put magic lube on the o rings. Water comes out fro where the flange from the top lines up with the bottom manifold Afraid to overtighten the clamp
    Pool built in 1999 23,000 gallons, 2 hp Pentair Whisperflow, Clean and Clear 520, Caretaker 99, Fiberstars 6008 Ultra Pure ozonator

  4. Back To Top    #4

    Join Date
    May 2016
    Location
    Las Vegas, NV
    Posts
    7

    Re: Caretaker leaking at valve

    cleaned it well and it is still leaking
    Pool built in 1999 23,000 gallons, 2 hp Pentair Whisperflow, Clean and Clear 520, Caretaker 99, Fiberstars 6008 Ultra Pure ozonator

  5. Back To Top    #5

    TFP Guide


    Join Date
    Feb 2015
    Location
    Chandler AZ
    Posts
    744

    Re: Caretaker leaking at valve

    Did you tap the band clamp as you were tightening it? Does it have a nut on the clamp or a thumb screw to tighten by hand?

    Did you tighten it as much as it was prior to disassembly? While my system is from a different manufacturer, I can clearly see how far it was previously tightened by looking at the threaded shaft of the band clamp.

    It's probably not tightened enough. With the pump off, try going a quarter turn more. Turn the pump on and see if it stops or at least slows down.
    Gene
    ​12,300 gal IG play pool - Pebbletec - built 10/1999 || Hayward S360SX 36" sand filter || Hayward Ecostar SP3400 VSP || A&A In-Floor cleaning system || Quik Water Leveler || Quik Dek-clor (limited use)
    TF-100 testkit / Speedstir - A good test kit is not an expense, it's an investment

  6. Back To Top    #6

    Join Date
    May 2016
    Location
    Las Vegas, NV
    Posts
    7

    Re: Caretaker leaking at valve

    Quote Originally Posted by proavia View Post
    Did you tap the band clamp as you were tightening it? Does it have a nut on the clamp or a thumb screw to tighten by hand?

    Did you tighten it as much as it was prior to disassembly? While my system is from a different manufacturer, I can clearly see how far it was previously tightened by looking at the threaded shaft of the band clamp.

    It's probably not tightened enough. With the pump off, try going a quarter turn more. Turn the pump on and see if it stops or at least slows down.

    I tried this before you suggested it and wound up breaking the clamp, I have a new one coming and I will see if that helps. Thank You!
    Pool built in 1999 23,000 gallons, 2 hp Pentair Whisperflow, Clean and Clear 520, Caretaker 99, Fiberstars 6008 Ultra Pure ozonator

  7. Back To Top    #7

    TFP Guide


    Join Date
    Feb 2015
    Location
    Chandler AZ
    Posts
    744

    Re: Caretaker leaking at valve

    Oh no!

    Last time I replaced the lid o-ring, I had a small leak. After messing with it for a couple days, I took it apart and found a small (and I mean very small) bit of dirt on the base where the band clamp sits. Cleaning that off fixed the issue.

    Was the rebuild kit a generic one or one from the manufacturer? Not sure about the size of o--rings in that generic kit - but i bought a generic o-ring for a multiport valve and never could get it to seal correctly.
    Gene
    ​12,300 gal IG play pool - Pebbletec - built 10/1999 || Hayward S360SX 36" sand filter || Hayward Ecostar SP3400 VSP || A&A In-Floor cleaning system || Quik Water Leveler || Quik Dek-clor (limited use)
    TF-100 testkit / Speedstir - A good test kit is not an expense, it's an investment

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •