Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: New pool owner fighting algae & filter keeps clogging

  1. Back To Top    #1

    Join Date
    Jun 2016

    New pool owner fighting algae & filter keeps clogging

    Good Morning. I have been fighting a green algae bloom in my pool for a while now. I really don't know much about pool care as it was my father in law's deal until this summer. I've been doing A LOT of reading and then found this forum!! Here is my question/problem. I have gotten the pool back to a cloudy blue, and have hooked the DE filter back up, but have added a minimal amount of DE. I know that it filters very fast and very well, but it is clogging every 2 minutes. I shut off the pump, recharge the filter, turn it back on; and then have to do it all over again every 2 minutes!! I've turned the SWG off as it does not like reduced flow and was just going to sleep rather than burning out the motor. I am going to vacuum this morning and try it again. My kids REALLY want to swim!!! Oh, and my CYA and FC levels are flatlined. Everything else looks ok, but all I have to test it are the little litmus strips. I cleaned the fingers on the filter last night, but then saw this morning that TSP might be better than Dawn. They are still rather green in spots, so should I soak them in a acid bath?? I also added 4 bags of salt last week as there was none in the pool at all.


    18' round AG, vinyl liner, Hayward Power-Flo Matrix pump w/ Hayward Extended Cycle D.E. Filter, SWG

  2. Back To Top    #2
    Mod Squad Texas Splash's Avatar
    Join Date
    Jun 2014
    South-Central Texas, Marion/San Antonio

    Re: New pool owner fighting algae & filter keeps clogging

    Hi Erin and welcome to TFP! Well two thing at the moment .... set your filter to recirculate if you have a multiport valve. Your algae problem is so heavy your filter is clogging like crazy. You'll never get rid of it. For that, you need to "SLAM" your pool (link below). That brings me to my next point ... test kit. The strips (and pool store) are useless. You must test your own water with either a TF-100 (link below) or Taylor K-2006C. Either one of those is what you need ASAP. Once you get either one of those (I recommend the TF-100), post a full set of numbers for us.

    In the meantime, add about 1/2 gallon of regular bleach to your water each evening. Add nothing else right now but regular (plain) bleach. Read the TFP SLAM and Pool School pages and you'll be all set once your kit arrives. Nice to have you with us.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    If you enjoyed your TFP experience, please consider donating to Support TFP!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts