Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Is my pump bad or does it just need priming? Makes a sound for 5 seconds then stops

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Houston, TX
    Posts
    22

    Is my pump bad or does it just need priming? Makes a sound for 5 seconds then stops

    My pump is a Pentair 3HP Challenger Pump. It's been ran 24/7 for about 2 years.

    While I was away, someone went to refill the feeder tabs and noticed the pump looked to be overheating. They turned off the pump, but also left the feeder cap off for a day or two.

    When I went back, I tried turning on the pump but no water was flowing through. It makes a sound for about 5 seconds then turns off for a minute, repeating.

    I tried 'priming' the pump, but I'm not sure if it's just the pump broken or I'm doing it incorrectly. It either barely circles the basket water or just makes the sound.

    All I'm doing is filling the basket with water to the top, sealing it back up, then starting the pump. My air pressure valve on my filter is also open. I've tried leaving it alone for an hour and I've also tried refilling the slowly draining basket again with water during pump off-times.

    Here is a picture of my setup:
    http://i.imgur.com/DPLMFYW.jpg

    My skimmer line works fine, it's just my main drain /heater line.

  2. Back To Top    #2

    Join Date
    Aug 2014
    Location
    Northern IL
    Posts
    4,615

    Re: Is my pump bad or does it just need priming? Makes a sound for 5 seconds then sto

    Bump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •