Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Normal to see DE in pool after filter cleaning?

  1. Back To Top    #1

    Join Date
    Feb 2016
    Location
    Los Angeles, CA
    Posts
    37

    Normal to see DE in pool after filter cleaning?

    I cleaned my filter this weekend and right after putting DE through the skimmer, I noticed the pool getting cloudy. Is it normal to see some DE get back into the pool after cleaning the filter? I let the filter run over night and everything seems to be normal now.

    Thanks
    22,000 gallon in ground pool with pebble finish. Pentair DE filter with Pentair VS pump. Built in the 70s but completely redone (including new pebble finish, equipment, and plumbing) in August 2015. K-2006.

  2. Back To Top    #2
    Casey's Avatar
    Join Date
    Apr 2007
    Location
    SW PA
    Posts
    10,157

    Re: Normal to see DE in pool after filter cleaning?

    I don't get DE in the pool after cleaning. Are your grids ripped or old? Did you over load it?
    I'd bet you my bikini you'll never get TFP water from a pool store!

    24' Sharkline Venture De Filter

  3. Back To Top    #3
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,198

    Re: Normal to see DE in pool after filter cleaning?

    You may get some blow out running the pump on high speed, but it shouldn't be more than a little puff.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  4. Back To Top    #4

    Join Date
    Feb 2016
    Location
    Los Angeles, CA
    Posts
    37

    Re: Normal to see DE in pool after filter cleaning?

    Quote Originally Posted by Casey View Post
    I don't get DE in the pool after cleaning. Are your grids ripped or old? Did you over load it?
    My pump is not even a year old so I really didn't bother checking the ribs in the filter. I just assumed they're still in good shape and not ripped. I guess I'll have to open it back up and check this weekend. Also, I put in 8 scoops of DE, which I've read is a good amount for my size filter. Thanks.

    - - - Updated - - -

    Quote Originally Posted by zea3 View Post
    You may get some blow out running the pump on high speed, but it shouldn't be more than a little puff.
    Yeah this was more than a puff. Enough to temporarily cloud my water. Would the first assumption be that there is a tear in one of the ribs? My filter is less than a year old but I guess something could have still torn it.
    22,000 gallon in ground pool with pebble finish. Pentair DE filter with Pentair VS pump. Built in the 70s but completely redone (including new pebble finish, equipment, and plumbing) in August 2015. K-2006.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •