Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Intellichlor IC40 Cell light flashing after 3 cleaning and inspection

  1. Back To Top    #1

    Join Date
    Jun 2016
    Location
    leesburg
    Posts
    3

    Intellichlor IC40 Cell light flashing after 3 cleaning and inspection

    My Intellichlor IC40 is ~4 years old. Low salt light was on last night so I added one bag as usual. Noticed this morning the Cell light started flashing green. Acid washed three times today and the cell light continues to flash. Disconnected the power for >45 minutes to "reboot" the system, no help still flashing. Holding the "more" button indicates I have ~60% cell life remaining. What to do next?

    Thanks in advance,
    Creek
    Creek

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Intellichlor IC40 Cell light flashing after 3 cleaning and inspection

    I believe some folks have been successful changing out the sensor.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    Join Date
    Jun 2016
    Location
    leesburg
    Posts
    3

    Re: Intellichlor IC40 Cell light flashing after 3 cleaning and inspection

    Thanks for the reply. Sensor? Can you say more? Thanks again.
    Creek

  4. Back To Top    #4
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Intellichlor IC40 Cell light flashing after 3 cleaning and inspection

    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  5. Back To Top    #5

    Join Date
    Jun 2016
    Location
    leesburg
    Posts
    3

    Re: Intellichlor IC40 Cell light flashing after 3 cleaning and inspection

    I tried doing a re-set by holding the "more" button down for 3 seconds 2 times each. No help. Wondering if the chlorinator is producing chlorine when the light is flashing?
    Creek

  6. Back To Top    #6

    Re: Intellichlor IC40 Cell light flashing after 3 cleaning and inspection

    The salinity sensor can’t be changed. It is a conductivity sensor that is built into the cell.

    The Temperature/Flow switch can be replaced, but it is probably not the problem.

    The “Inspect Cell” light flashes when the cell cannot maintain adequate chlorine production. This can be due to low salt, cold water or a dying cell. Production stops when the light is flashing.

    I would suggest getting the salt level to 3,800 ppm and then trying again. Verify the salt level using the Taylor K-1766 salt test kit.

    If the Cell light continues to flash with the salt at a definite 3,800 ppm, you probably need a new cell.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •