Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: pump issues

  1. Back To Top    #1

    Join Date
    Jun 2016
    Location
    Kellyton Alabama
    Posts
    1

    pump issues

    I recently bought a Coleman 1648 above ground pool. The pump just doesn't work well. The chemicals are not being moved chlorine levels are waaayyy too high and we just can't keep the water clean. I think it holds 10,000 gallons of water but not sure. I need to know what other pumps are out there I can get to help my family be able to swim and enjoy the pool. We've had it for 2 weeks and have only gotten in the pool twice because its just not clean

  2. Back To Top    #2
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,934

    Re: pump issues

    Hello and welcome to TFP! Coleman and Intex have many interchangeable fittings, so I believe you could upgrade to an Intex pump/sand filter combo for your pool and do just fine. A quick search on Amazon or Inyopools.com and you'll see what I mean. But remember, even a great pump/filter won't prevent algae - that's a chemistry issue. So make sure you are testing properly with one of the TFP recommended test kits (TF-100 or Taylor K-2006). If you don't have one of those, that should be your first priority. I highly recommend the TF-100 (link below). Nice to have you with us.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •