Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 13 of 13

Thread: Filter Help?

  1. Back To Top    #1
    DThompson55's Avatar
    Join Date
    Jun 2016
    Location
    Manchester, CT
    Posts
    21

    Filter Help?

    I have a Sta-Rite System:3 PLD50 DE filter 30 sq ft. It's like a big egg shaped thing that comes apart in the middle. Last year it was really hard to put back together. This year it's just not going back together. I've replaced the gasket. I've used the proper lube. I've put all my weight onto it. My wife and I have double-teamed it. It just doesn't work. I think it's seated properly but when I turn on the pump water just pours out in places all around the seam. So I take it apart and try again. Hours wasted. So maybe there's some technique I should be trying?

    If not, I'm guessing I need to buy a new filter. But we've had all sorts of other problems with this one in the past on top of what I just described. But I'll describe those later. I'm a complete non-pool person, so I might not be describing this well.

    Any suggestions?
    15k gallon AG. Sta-Rite System:2 PLM-100 DE filter. Hayward Power Flo LX Pump. TF-100 test kit. Nice and Blue thanks to TFP.

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Filter Help?

    Welcome to TFP!

    I am no pro on DE filters but these articles should help until some DE people stop by.
    Pool School - Maintenance and Cleaning of Pool Filters
    Use and care for DE filters
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    TFP Guide

    Kiss4aFrog's Avatar
    Join Date
    May 2013
    Location
    Hudson, WI
    Posts
    2,602

    Re: Filter Help?

    What are you using for a lubricant ??
    '70s IG Vinyl 32K gal, Lazy L, Hayward SuperPump 1.5hp 120V, S240 Sand Filter W/DE
    Solar Blanket, Well Water, Borax Added, TF-100 tester. ? too cold
    1979, 275gal Conway Emerald Spa P-100-2, ES-2 Spa Pack, bromine floater, indoor
    TF-100, Best test kit - TFTestkits.net
    Please help keep the lights on, become a TFP Supporter!

  4. Back To Top    #4

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,084

    Re: Filter Help?

    Any suggestions?
    Cut your losses. A Pool Guy will get it on for you in a few minutes.....assuming you have the right gasket.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  5. Back To Top    #5
    DThompson55's Avatar
    Join Date
    Jun 2016
    Location
    Manchester, CT
    Posts
    21

    Re: Filter Help?

    Thank you! Neither of the descriptions in the articles match what we have to do to clean this beast. There's no backwash option on this, nor any kind of bump option. We have to take it apart, hose down the filter, reassemble, start the pump and add a few lbs of DE at least once a week during algae season, and less frequently after that. On a good day it takes 20 minutes and your sneakers get soaked with an algae/DE slurry. It sounds like a different filter might have some better options and might be a good investment.

    - - - Updated - - -

    I appreciate that. Last year I paid the 60 bucks it takes to get them to do a house call. And they got it put back together. But I can't pay 60 bucks every week or two.

    - - - Updated - - -

    Several, but always silicone based. Hayward Lube recently. Comes in a tube.

    15k gallon AG. Sta-Rite System:2 PLM-100 DE filter. Hayward Power Flo LX Pump. TF-100 test kit. Nice and Blue thanks to TFP.

  6. Back To Top    #6

    TFP Guide

    Kiss4aFrog's Avatar
    Join Date
    May 2013
    Location
    Hudson, WI
    Posts
    2,602

    Re: Filter Help?

    From the looks of it I'd guess the gasket is moving out of place. I haven't seen one like it before. The photo shows the lid screws down. Is there a groove or something that's supposed to position the gasket when you screw down the top ??
    '70s IG Vinyl 32K gal, Lazy L, Hayward SuperPump 1.5hp 120V, S240 Sand Filter W/DE
    Solar Blanket, Well Water, Borax Added, TF-100 tester. ? too cold
    1979, 275gal Conway Emerald Spa P-100-2, ES-2 Spa Pack, bromine floater, indoor
    TF-100, Best test kit - TFTestkits.net
    Please help keep the lights on, become a TFP Supporter!

  7. Back To Top    #7
    DThompson55's Avatar
    Join Date
    Jun 2016
    Location
    Manchester, CT
    Posts
    21

    Re: Filter Help?

    "assuming you have the right gasket." - Brilliant... that's the kind of thinking I needed. Thanks, It shouldn't be, but maybe it is the wrong gasket. There's no way to know. So I've just ordered what appears to be the correct part. I'll check back in when that arrives.
    15k gallon AG. Sta-Rite System:2 PLM-100 DE filter. Hayward Power Flo LX Pump. TF-100 test kit. Nice and Blue thanks to TFP.

  8. Back To Top    #8
    DThompson55's Avatar
    Join Date
    Jun 2016
    Location
    Manchester, CT
    Posts
    21

    Re: Filter Help?

    Yes, the two halves nest, the gasket is supposed to fit between them, there's an indentation in both halves where the gasket fits. And then there is a ring that screws down and tightens the assembly locking the two halves in place. I'll just order a new gasket and see if that fixes anything. That's a lot cheaper than a whole new filter unit.
    15k gallon AG. Sta-Rite System:2 PLM-100 DE filter. Hayward Power Flo LX Pump. TF-100 test kit. Nice and Blue thanks to TFP.

  9. Back To Top    #9


    TFP Guide

    kcindc's Avatar
    Join Date
    Sep 2011
    Location
    Fairfax, VA
    Posts
    1,272

    Re: Filter Help?

    Wow, this filter is a combo of cartridge and DE. Seems like a pain to clean. If possible, I suggest adding a multiport valve so that you can backwash. I love my DE filter.

    There is no such thing as algae bloom season. Algae grows when your FC is too low for your CYA level. The methods taught on this forum eliminates the possibility of algae if you follow the methods here.

    Here is a link to parts manual for the model you listed: http://www.pentairpool.com/pdfs/S339CEngOM.pdf
    Last edited by kcindc; 06-20-2016 at 01:00 PM. Reason: link to manual
    Karen
    33K IG w spa plaster, Pentair 1HP Whisperflo, DE Filter, SWG CircuPool RJ-60, Dolphin Triton Plus, Raypak Dig 336K BTU, TF-100.
    Pool Math Chlorine / CYA Chart SLAM - Shock Level And Maintain
    2017 replaster/retile

  10. Back To Top    #10
    DThompson55's Avatar
    Join Date
    Jun 2016
    Location
    Manchester, CT
    Posts
    21

    Re: Filter Help?

    Thanks for the link to the filter diagram. I think I have the right replacement o-ring on order. I have never understood FC. I keep the chlorine float filled with pellets at all times, but chlorine still stays low. We bring the water in to have it tested a couple times a month when it's green, and they tell us the chemicals levels are good, but they tell us the chlorine is low. Maybe I just need to try using a few floats instead of just one. But we'll get to the green topic once the filter is running again.
    15k gallon AG. Sta-Rite System:2 PLM-100 DE filter. Hayward Power Flo LX Pump. TF-100 test kit. Nice and Blue thanks to TFP.

  11. Back To Top    #11


    TFP Guide

    kcindc's Avatar
    Join Date
    Sep 2011
    Location
    Fairfax, VA
    Posts
    1,272

    Re: Filter Help?

    The pool store in the business of getting money out of your wallet. Order one of the recommended test kits ASAP. The TF-100 is the most economical and you'll need the XL option since you have green water. TFTestkits.net

    While waiting for your kit, read up on pool school and add 1 jug of 8.25% of bleach a day. Wal-Mart great value is an economical and usually convenient option. Post up your first results from your kit and we'll help you from there.
    Karen
    33K IG w spa plaster, Pentair 1HP Whisperflo, DE Filter, SWG CircuPool RJ-60, Dolphin Triton Plus, Raypak Dig 336K BTU, TF-100.
    Pool Math Chlorine / CYA Chart SLAM - Shock Level And Maintain
    2017 replaster/retile

  12. Back To Top    #12
    DThompson55's Avatar
    Join Date
    Jun 2016
    Location
    Manchester, CT
    Posts
    21

    Re: Filter Help?

    System3 PLD50 Manual - http://www.pentairpool.com/pdfs/PRDSYSOM.pdf

    I discovered the hard way that the gaskets for the System2 do not fit the System3, or perhaps they sent me the wrong parts. So re-ordering what might be the right part today, that is if it is, in fact, the 27001-0061S gasket that I want.
    15k gallon AG. Sta-Rite System:2 PLM-100 DE filter. Hayward Power Flo LX Pump. TF-100 test kit. Nice and Blue thanks to TFP.

  13. Back To Top    #13
    DThompson55's Avatar
    Join Date
    Jun 2016
    Location
    Manchester, CT
    Posts
    21

    Re: Filter Help?

    Just to close this thread - There was definitely something wrong with the 20 year old PLD50 Filter. It might have gone out of round or something else, but nobody could get the filter back together by the end of last season. We took it to the town dump and bought a new Sta-Rite, and it goes together and comes apart effortlessly, just like I remember the old filter working several years back.
    15k gallon AG. Sta-Rite System:2 PLM-100 DE filter. Hayward Power Flo LX Pump. TF-100 test kit. Nice and Blue thanks to TFP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •