Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Hayward Aqua Trol panel not reading correct salt level

  1. Back To Top    #1

    Join Date
    Jun 2016
    Gatineau, Québec, Canada

    Hayward Aqua Trol panel not reading correct salt level

    Hello everyone,

    I'm having a problem with my Hayward Aqua Trol panel since opening my pool last month.

    The panel reads 300 ppm of salt which is not high enough to start generating salt and the generating salt light turns red. The reading went as low as 0 ppm and as high as 600 ppm but won't go higher. I know I have the correct amount of salt (tested in store).

    I had the store test the cell on a new panel and the cell worked fine identifying the right amount of salt. The store tested a new cell on my defective panel and the panel reads 300 ppm.

    The store unfortunately told me they hadn't received the equipment to test the panel so I took everything back and that's where I am. (I not impressed by the service received by that store...). Any ideas?

    13,593 Gallon, Above Ground, Cartridge Filter, Haward salt generator (Not currently working), sunny all day, Taylor K-2006

  2. Back To Top    #2
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Central Minnesota

    Re: Hayward Aqua Trol panel not reading correct salt level

    Sounds like you need a new panel.
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts