Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Hayward H150 Pool Heater troubleshooting

  1. Back To Top    #1

    Join Date
    Jun 2013
    Location
    Green Bay, WI
    Posts
    72

    Hayward H150 Pool Heater troubleshooting

    We bought our house a year ago and it came with a pool and the H150 heater. I didn't even both plumbing it in last year, but i did this year when i went to a rigid system.
    Anyway, we've got a pool party this weekend so i thought i'd try to fire it up in case the kids get cold.

    I opened the valve on the gas pipe coming out of the ground going to the heater. I flipped the switch to ON. Nothing.
    I opened the front panel and tried following the directions on that and still nothing.

    So where do i even begin?!
    Attached Images Attached Images
    Doughboy 24' x 48" (AG), AQUA Tools Cartridge Filter, Frog System
    2004 Sundance Cameo SPA

  2. Back To Top    #2

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,562

    Re: Hayward H150 Pool Heater troubleshooting

    Is the pilot light lit?

    Page 24 on this manual has the needed instructions for this... https://www.hayward-pool.com/pdf/man...eries-hxxx.pdf
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  3. Back To Top    #3

    Join Date
    Jun 2013
    Location
    Green Bay, WI
    Posts
    72

    Re: Hayward H150 Pool Heater troubleshooting

    I followed the "Light Instructions" on page 22 of the manual (same as instructions listed on inside of cover) with no luck. However, with the front panel off, i'm not sure where i'm supposed to be looking for the pilot light
    It says to the far left of the burner tube...didn't really see anything that would look like a pilot light.
    Shouldn't i have smelled gas at some point while holding down the pilot knob?
    Doughboy 24' x 48" (AG), AQUA Tools Cartridge Filter, Frog System
    2004 Sundance Cameo SPA

  4. Back To Top    #4

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,562

    Re: Hayward H150 Pool Heater troubleshooting

    OK, Is the gas on???

    See the silver tube and wire from the gas control valve? follow them down to where they go under the flame panel. The silver tube is the pilot supply tube. It is possible that the pilot assembly may need to be cleaned out. The pilot flame has to be in the path of one of the three burner tubes. Those are the three round things in a row.
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  5. Back To Top    #5

    Join Date
    Jun 2013
    Location
    Green Bay, WI
    Posts
    72

    Re: Hayward H150 Pool Heater troubleshooting

    I opened the valve so i assume it's on. Whether or not it's flowing i don't know.
    So where the tube goes underneath and terminates is where i should see a flame?
    When i flipped the switch to "ON", i didn't hear anything turn on or run....should i?
    Doughboy 24' x 48" (AG), AQUA Tools Cartridge Filter, Frog System
    2004 Sundance Cameo SPA

  6. Back To Top    #6

    Join Date
    Jun 2013
    Location
    Green Bay, WI
    Posts
    72

    Re: Hayward H150 Pool Heater troubleshooting

    So i gave up on this heater shortly after this post in 2016....needless to say here i am 2 years later ready to try again.

    So step 1 is to get this pilot lit. Is it safe to say i'll have to remove the left panel to reach this pilot? When i look at page 32 of this manual https://hayward-pool-assets.com/asse...f?fromCDN=true it looks like the pilot would be a little ways back in there.
    Doughboy 24' x 48" (AG), AQUA Tools Cartridge Filter, Frog System
    2004 Sundance Cameo SPA

  7. Back To Top    #7

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,709

    Re: Hayward H150 Pool Heater troubleshooting

    I would pitch it out and get a new one.
    Paul
    http://www.gastekservice.com If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,
    Check out some videos on my YouTube channel - http://www.youtube.com/c/Gastekservices

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •