Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Intex Krystal Clear Sand Filter 1500 no suction

  1. Back To Top    #1

    Join Date
    Jun 2016
    Location
    NE Kansas
    Posts
    16

    Intex Krystal Clear Sand Filter 1500 no suction

    First I'm going to apologize because I don't know the technical terms for things. Hopefully I can get my point across without confusing anyone. We just bought our first pool, the Intex 18x9 rectangular ultra frame, and we got everything set up, ground level etc. I prime the pump like the instructions direct and turn on the pump to filter and notice that the outlet from the filter into the pool is pushing water out great. I go to check the suctions from the two inlets from the pool to the filter and there is no suction. I checked the pressure and it is in the green right below the yellow.

    We have tried priming it again, tried cleaning everything, checked all connections etc. Everything seems to be working well except the suction. Maybe I'm just not sure how this goes and maybe I won't feel suction. I just want to make sure I'm doing everything correctly since I'm new to this. Any help would be appreciated!

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Intex Krystal Clear Sand Filter 1500 no suction

    Welcome to TFP! Congrats on the new pool!

    It is designed that way to have less suction to avoid entrapment of children against the suction inlet. As long as the pressure gauge is good and water outlet pressure is good everything is fine. If water flow drops or the pressure gauge rises 20-25% the backwash the filter.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    Join Date
    Jun 2016
    Location
    NE Kansas
    Posts
    16

    Re: Intex Krystal Clear Sand Filter 1500 no suction

    Thank you for your response. So what you are saying is that I won't feel the suction at all?

  4. Back To Top    #4
    jmcdtucson's Avatar
    Join Date
    Jun 2014
    Location
    Tucson, AZ
    Posts
    314

    Re: Intex Krystal Clear Sand Filter 1500 no suction

    Yes, that sounds perfectly normal. As long as water is coming out you are good.
    Intex 12'x24'x52"
    8,403 gallons
    Intex SF60110 2450 GPH Sand Filter
    Intex CS8110 SWG
    Aquabot AJET121I Pool Rover S20-40

  5. Back To Top    #5
    eblade21's Avatar
    Join Date
    Jun 2014
    Location
    Lynbrook, NY
    Posts
    23

    Re: Intex Krystal Clear Sand Filter 1500 no suction

    Yes they are all right you shouldn't feel any suction at all. You would here an intex pump whine if you had a suction issue. I found sometimes if you feel the return jet has a low flow, go to the hose between the pump and the sand filter an loosen a bit till water comes out this will relief the air caught in the system.
    But again like everyone said the guage will tell you everything.
    Hope this helps
    Eddie
    Summer Escapes 14' Pro-Series 4047 gallons; Intex 12 inch Sand Filter Pump; Intex SWCG; Vinyl Works Fence; Taylor K-2006C and Taylor K-1766, Intex 14 Inch Sand Filter Pump
    Sungrabber 4 x 12 feet Solar Collector controlled by Hayward Aqua Solar GL-235
    12 mil Clear Solar Blanket on SolarRoller; Aquabot Reaction

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •