Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: I think I goofed. Help me?

  1. Back To Top    #1

    Join Date
    Jun 2016
    Springfield, GA

    Question I think I goofed. Help me?


    So, first things first: I've got a 14' round vinyl pool, about 3300 gallons.

    My area had some serious rain a couple of weeks ago, and I ended up with a pool the prettiest shade of dark green you ever did see. After trying different products and approaches I ended up shocking it to within an inch of its life and ended up with milky blue water...hooray!

    But. Because I'm an impatient turdhead and couldn't wait a few more days for the water to clear on its own, I tossed some floc in there. The floc worked like it was supposed to and a little over 24 hours later I had clear water with a few piles of dead algae. Hooray again!

    Since my pump doesn't have a vacuum to waste option, I used the vacuum and hose, got some siphon action goin' on, and basically "vacuumed" the pool that way.

    It was working beautifully, but then I noticed a few spots that seemed to be clinging to the pool's surface. So in my infinite wisdom I decided to brush those spots and come back after it settled to finish the clean up. However, it has been a few hours and it hasn't settled. Uh oh. Did I undo everything I've done to this point? Am I being an impatient turdhead again and just need to give it some more time?

    Any advice or insight will be appreciated. TIA.

    Oh. And it just started raining again as I type this. Welcome to summer in southeast Georgia.

  2. Back To Top    #2
    Mod Squad
    Join Date
    Aug 2012
    DFW, TX

    Re: I think I goofed. Help me?

    Welcome to TFP!

    We prefer a little more methodical approach.

    A good test kit like the TF-100 from and this process, SLAM
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    Join Date
    Mar 2016
    James Island, SC

    Re: I think I goofed. Help me?

    You're not alone. I'm not too far up the road from you in Charleston. My FC level dropped too much recently after the Memorial weekend tropical storm and my pool also turned a nice light green. I'm currently in the SLAM process.
    IG 16'x32' approx. 15,000 gal., vinyl liner last replaced in 2012, built in ???, Intellichlor SWG, Sand Dollar sand filter, old rusty looking GE pump, standard TF-100 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts