Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: need a little advice

  1. Back To Top    #1

    need a little advice

    Every year I open my pool I have leaks. The worst place is always the two conections from my multiport to my sand filter. I back them off, then tighten them a little bit at a time. Still a slow or fast drip. Should I replace those things that screw on? Do they wear out? I think I need a new sand filter. It has a small crack around where all the bolts are. And it has always leaked there. Also I have never been able to use my skimmer. there is a small leak somewhere. I always have a little air in the system. Do multiports wear out? I probably need to hire a pro. Not sure who to use here in southern maine. Thanks.
    18k IG 16'x32' vinyl liner Haywood S-200 high rate sand filter pump Haywood Encl.3 1hp A.O.Smith Corp

  2. Back To Top    #2

    TFP Guide
    cowboycasey's Avatar
    Join Date
    Jul 2013
    Fletcher, OK

    Re: need a little advice

    could you upload a picture of what your talking about, maybe someone will be able to help
    Pool: Intex 16x32 15000 gal, 2 speed 340042, Pentair CC320 Filter, CircuPool SJ45 Salt System, Intermatic PE653RC; Hot Tub: 650 Gal SWG Megachlor
    links: pool school * Recommended-Levels * SLAM * CYA chart * Test kits * How To Post Pictures * Poolmath * OCLT ** Support your website if we helped you :) **

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts