Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Clearwater Zodiac LM2-24 SWG unit problems with output control button

  1. Back To Top    #1

    Join Date
    Jun 2016
    Location
    France (Dordogne) 24550
    Posts
    2

    Clearwater Zodiac LM2-24 SWG unit problems with output control button

    Inground pool - 50 m3-Clearwater Zodiac LM2-24 SWG unit-Zodiac Ph Perfect-France/Dordogne

    I am having issues with my Clearwater Zodiac LM2-24 SWG unit. The output control button to increase the salt production does not seem to work. When this button is pressed, the LED's on the panel should go up one by one. When pressed once, the led's go up to 4, one press more 5 Led's are green. Super chlorinate led is OK.
    So I can't control the output to 2 or 3 Led's.
    Reset didn't help.
    In-ground pool,50 m3, Zodiac Clearwater LM2-24, Zodiac pHperfect.

  2. Back To Top    #2

    Join Date
    Jul 2016
    Location
    London/Ontario
    Posts
    1

    Re: Clearwater Zodiac LM2-24 SWG unit problems with output control button

    Quote Originally Posted by Jon Vismans View Post
    Inground pool - 50 m3-Clearwater Zodiac LM2-24 SWG unit-Zodiac Ph Perfect-France/Dordogne

    I am having issues with my Clearwater Zodiac LM2-24 SWG unit. The output control button to increase the salt production does not seem to work. When this button is pressed, the LED's on the panel should go up one by one. When pressed once, the led's go up to 4, one press more 5 Led's are green. Super chlorinate led is OK.
    So I can't control the output to 2 or 3 Led's.
    Reset didn't help.
    Did you end up getting an answer to this? Mine does the exact same thing at times. Reset button doesn't do anything. Superchlorinate works. Turning on and off doesn't work either. I tested my water though and all my levels are good. Chlorine is right where it needs to be. The last time it happened it just seemed to start working after a bit. I'm wondering, does it do this during some kind of self-cleaning mode or something?

  3. Back To Top    #3

    Join Date
    Jun 2016
    Location
    France (Dordogne) 24550
    Posts
    2

    Cool Re: Clearwater Zodiac LM2-24 SWG unit problems with output control button

    Quote Originally Posted by MrModus View Post
    Did you end up getting an answer to this? Mine does the exact same thing at times. Reset button doesn't do anything. Superchlorinate works. Turning on and off doesn't work either. I tested my water though and all my levels are good. Chlorine is right where it needs to be. The last time it happened it just seemed to start working after a bit. I'm wondering, does it do this during some kind of self-cleaning mode or something?

    No answer. I presume it's just a defect in the LED unit. By pressing several times, as you normally do to increase the activity, the light becomes brighter. And, in a situation with low salt, the light:" low salt" goes on after pressing 3 times and becomes brighter after pressing 4 times. So the system is ok and te levels are also ok (after adding salt). You just have to count the pressure times to reach the desired level. I HOPE this is the solution........thank you for your reply.
    In-ground pool,50 m3, Zodiac Clearwater LM2-24, Zodiac pHperfect.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •