Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: HELP - Added stabilizer incorrectly, did I ruin the pool?

  1. Back To Top    #1

    Join Date
    May 2015
    Location
    Wapella, IL
    Posts
    26

    HELP - Added stabilizer incorrectly, did I ruin the pool?

    This is year number 2 of me managing our pool and I was doing so well. I slammed it, it's clear, all the numbers were great except CYA. I am going through chlorine like crazy so I did pool math and knew I needed to add stabilizer. I got ahead of myself and I added the granulars by just pouring it in (not in a sock or slowly to the skimmer). Now it's all at the bottom of my pool...just sitting there. Please tell me this can be fixed?!
    27' round AG pool, 48" high, 17,100 gallons
    120 Sq ft. SwimPro Cartridge Filter, A.O.Smith pump
    SmartClean Pool Kleen Robotic Pool Cleaner

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: HELP - Added stabilizer incorrectly, did I ruin the pool?

    Vacuum it up and let it dissolve in the filter. Hopefully you won't need to backwash for a few days.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3
    Isaac-1's Avatar
    Join Date
    May 2010
    Location
    SW Louisiana
    Posts
    6,711

    Re: HELP - Added stabilizer incorrectly, did I ruin the pool?

    What Richard said, vacuum it up into the filter and don't clean the filter for a few days, CYA is very slow to dissolve, it is also acidic so this way at least it will not be damaging your liner.
    Indoor 20x40 35,000 gallon vinyl pool with 1.5 HP 2 speed Jandy FloPro pump, Hayward EC75 Perflex DE filter, 11 4x12 Techno-Solis solar panels w/ Aquasolar controller, Aquabot Turbo T Robot Cleaner. Also LMI metering chlorine dispenser pump and HotSpring Jetsetter
    I use and endorse TFtestKits TF-100 from http://tftestkits.net
    ~Remember TFP counts on your donations to keep this site ad free~

  4. Back To Top    #4

    Join Date
    Sep 2010
    Location
    Noblesville, IN
    Posts
    104

    Re: HELP - Added stabilizer incorrectly, did I ruin the pool?

    I added it to the skimmer and seemed to work ok without a sock.

    16 x 32 15300 gal. IG Vinyl Jandy pump, Jandy sand filter, Paramount circulation system, Automatic pool cover.

  5. Back To Top    #5
    Isaac-1's Avatar
    Join Date
    May 2010
    Location
    SW Louisiana
    Posts
    6,711

    Re: HELP - Added stabilizer incorrectly, did I ruin the pool?

    The problem with adding CYA to the skimmer is if you need to backwash before the CYA dissolves (which may take a few days depending on brand) you loose any CYA left in the filter.
    Indoor 20x40 35,000 gallon vinyl pool with 1.5 HP 2 speed Jandy FloPro pump, Hayward EC75 Perflex DE filter, 11 4x12 Techno-Solis solar panels w/ Aquasolar controller, Aquabot Turbo T Robot Cleaner. Also LMI metering chlorine dispenser pump and HotSpring Jetsetter
    I use and endorse TFtestKits TF-100 from http://tftestkits.net
    ~Remember TFP counts on your donations to keep this site ad free~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •