Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Problem with Krystal Clear Sand Filter Pump Model SF90110T

  1. Back To Top    #1

    Join Date
    Jun 2014

    Problem with Krystal Clear Sand Filter Pump Model SF90110T

    Hi. First-time poster. I set my 9x18 INtex pool up two weeks ago, pump was working fine, it's our second year. Then on Saturday when i was about to head out for the day i turned it on and i could hear it sounded funny, would run for a bit, fade, and run for a bit, but i was in so much of a rush i didn't deal with it.

    when i got back it wouldn't run. If i turn it on you can here a subtle electronic sound but nothing happens.

    did my pump burn out? what caused that? Is my only option to order a new one?

    See photo below. I also wanted to ask if i set up the sandfilter pump and the saltwater pump system properly.

    Attached Files Attached Files
    Intex 9x18 above ground pool purchased in 2014 but not set up till spring of 2015. Came with sand filter and pump but i bought the salt water system.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Problem with Krystal Clear Sand Filter Pump Model SF90110T

    If the suction is on the right and the return is on the left then it appears that you have it plumbed correctly.

    Unfortunately those pumps aren't very repairable. Can you turn the motor by hand?
    How loud of a hum do you hear? It could be a capacitor issue. I'm not sure what the capacitor looks like on those motors.
    They don't list any parts for this motor except the complete motor and controls.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts