Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Help! - IntelliTouch acting crazy

  1. Back To Top    #1

    Help! - IntelliTouch acting crazy


    Sorry for the long post.

    We've had our pool for about 8 years now. At the time, we installed top of the line Pentair equipment. Aside from the Salt Chlorinator (IC40), which I gave up on long ago after going through multiple of them in a short period of time, the equipment has been working pretty good. About two months ago, I noticed both (one in the pool and one in the spa) spa side remotes (IS10) started acting very odd until they both stopped working. Then one day I noticed that the pumps were not running. I went out to examine and noticed that the 12v breaker on the personality board was tripped. I reset it and started things back up, but it tripped again. By process of elimination, I determined the perhaps the IS10's were causing the issue, so I disconnected both of them from he COM serial ports and that seemed to fix the problem. Fast forward to today. I was in the other room and kept hearing the touch panel beep every few seconds. Upon examining, it looked like it was turning on and off. I went out and it appeared that the pumps weren't on either and somehow it was in service mode. I power cycled things and then put it back to auto. The touch panel in the house came back on, but now the Variable Speed Pump (Out main filter pump) was turning on, and seemed like it was struggling to prime, even though it looked as though it was primed just fine. It kept on jumping up in speed and then would drop down and slowly start ramping up until eventually it just stopped with a priming alert. After checking plumping and cleaning out everything, I gave it another shot...Same thing! I started to think something was wrong with the pump. I decided to disconnect the pump from the Intellitouch by unplugging the cable that goes into the COM port and then just ran the pump in filter mode on it's own. It worked fine! Is it possible the COM port on the PCB circuit board is causing everything to go haywire. Any advice or tips? Has anyone ever replaced the circuitry on the COM ports. I'm think perhaps one of the IS10's damaged the circuitry. Thanks in advance.


  2. Back To Top    #2

    Re: Help! - IntelliTouch acting crazy

    So I let the pump run on it's own (detached) from the intellitouch controller for a few hours. Worked fine that who time. During that time I turned the power off to the Intellitouch system. I decided to try it one more time. I powered on the Intellitouch (started off in service mode), waited about 10 minutes, plugged the communication cable back into the pump and switched intellitouch back to auto. Everything seems to be working as it should. I'm just hoping the problem doesn't return. I still would like to have any advice anyone has.

  3. Back To Top    #3

    Join Date
    Dec 2014
    Riverside California

    Re: Help! - IntelliTouch acting crazy

    Since you had a breaker trip with no apparent reason you may have had an electrical spike or surge which blew the breaker and also upset the program running in your Intellitouch system causing multiple symptoms. Powering the Intellitouch off and then back on again restarted the microprocessor in the intellitouch and corrected the symptoms you had.

    Do you have a surge protector for your system? If not, you should get one installed. I have two, one on my main panel to the house, and another right on my automation panel. The surge protector will also protect your VS pump electronics which are very sensitive to power surges.
    38000 Gal, IG, Plaster, 20' x 40' x 10', Attached Raised Spa, Intelliflo VS 3 HP (011018), Pentair Quad DE 60 Filter, Raypak (Rheem) 400,000 BTU (407a low Nox), Easy Touch 8 upgrade, Screenlogic 2 with wireless, IS-4 Spa Side Remote, Stenner 45MPHP10 w/15 gal tank, Intellibrite 5g (3), Dolphin Triton Plus robot with PRO remote, Water Tech Catfish handheld vacuum for spa, TF100 with SpeedStir.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts