Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: small leak at filter clamp

  1. Back To Top    #1

    Join Date
    Sep 2007
    Gloucester County, NJ

    small leak at filter clamp

    my PB came by over the weekend to fix a problem with my heater. Today as I was working in the pool area, I noticed that my pressure was lower than normal and I had a small leak at the filter clamp. I ended up tightening the clamp as it was not fully tightened. We after getting as tight as I could by hand, the pressure was up to where I normally had it (16 vs. 12), but I still notice a very small leak. I'm guessing that I need to take the filter apart, make sure the O-ring is OK and put it back together. What should I be looking for to be sure all is OK?
    28,000 gallon gunite/white plaster with 30ft RBB and 2ft sheer descent, 100 sq ft thermaledge, 50sq ft spa w/ 6 jets
    2HP Jandy pump, 60sq ft Jandy DE filter, 400,000 BTU Jandy LX Nat Gas Heater, 2 Jandy color lights + Jandy color spa light, Jandy Aqualink RS6, Jandy AquaPure 1400

  2. Back To Top    #2
    spishex's Avatar
    Join Date
    Oct 2008
    Hillsborough, NC

    Re: small leak at filter clamp

    It probably just got a little grime on it the last time it was opened. Clean both the o-ring and the track for it on both sides of the filter housing.

  3. Back To Top    #3

    Join Date
    Mar 2007
    Coastalish 'down easter'

    Re: small leak at filter clamp

    Let's not forget to apply a little pool lube (teflon or silicon based) to the o-ring 8)
    Luv& Luk

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts