Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: DE added to Sand Filter. ???

  1. Back To Top    #1

    Join Date
    May 2013
    Location
    Tulsa, OK
    Posts
    83

    DE added to Sand Filter. ???

    I just added 1cup of DE diluted in water to my sand filter. I was expecting a pressure increase but I actually lost 3psi almost immediately. Should i continue to add DE until i reach my 1 psi gain? Or is there another issue going on?
    12x24 Doughboy. 8700 gallons~ 2 HP Dyanmo Pump~ 26" Sand Dollar Filter~TF 100 test kit~ Zodiac Ranger AGP automatic cleaner.

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: DE added to Sand Filter. ???

    Wait a few minutes. Could be a clump of DE is clogging the pump impeller. Give it time to dissolve.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3

    Join Date
    May 2013
    Location
    Tulsa, OK
    Posts
    83

    Re: DE added to Sand Filter. ???

    Okay. My normal clean filter pressure is 9-10psi.
    Added DE 1 hour ago and pressure is staying at 7psi.
    DE was diluted in water completely prior pouring in skimmer.
    I am also getting some bubbles from the return eye now.
    Should I backwash and start again with the DE addition and see how the pressures react?

  4. Back To Top    #4
    Mod Squad YippeeSkippy's Avatar
    Join Date
    Jan 2012
    Location
    'burbs of Augusta, Georgia
    Posts
    6,491

    Re: DE added to Sand Filter. ???

    There is no hard fast amount of DE that it takes to raise your psi 1 pound. So if it were me, I'd try another 1/2 cup and see where that takes it. Just add it slowly, or as you did diluted in water added slowly.

    If you want to backwash it out at ant time no harm will have been done.
    My Amazon Smile for November12K Fiberglass IG, Infinity 4000 automatic cover, SWCG, Hayward Sand Filter, Hayward 1.5 Pump, Doheny Discovery Robot, Savi Melody LED pool lights, outdoor speakers and other assorted doo-dads. Sundance Altamar Hot Tub.
    Our pool build--> Our Pool Solved Our Sloping Yard Skippy's Cheap Pool Cooler -->Skippy's New Fountain

  5. Back To Top    #5
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: DE added to Sand Filter. ???

    Quote Originally Posted by heavyweight_4u View Post
    Okay. My normal clean filter pressure is 9-10psi.
    Added DE 1 hour ago and pressure is staying at 7psi.
    DE was diluted in water completely prior pouring in skimmer.
    I am also getting some bubbles from the return eye now.
    Should I backwash and start again with the DE addition and see how the pressures react?
    Low pressure and bubbles sound more like an air leak. Did you, by chance, backwash just before adding DE? Maybe the water level is now too low and you have a vortex in the skimmer. Go take a look. If you see a whirlpool, there's your air bubbles and low pressure. Fixing that is as easy as dropping the hose in.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  6. Back To Top    #6

    TFP Guide

    AimeeH's Avatar
    Join Date
    Apr 2012
    Location
    Columbia SC
    Posts
    1,837

    Re: DE added to Sand Filter. ???

    Ok. If you have a larger problem, I'm sure Richard and other experts can help get you straightened out BUT.........this happened to me this year too. Pressure had seemingly been about 1 pound lower than normal for a long while. I added DE and my pressure dropped. I went nuts thinking I had a blockage. Long story short......my gauge was bad. That drop when I added DE was my first sign.
    18*36*23 true "L" vinyl IG 29,000 gallons. SWG. TF-100 test kit.
    http://tftestkits.net/splash-page.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •