Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Jandy CV460 Cartridge Filter - Having Trouble with Clamp Ring Knob Assembly

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    Voorhees, NJ
    Posts
    49

    Jandy CV460 Cartridge Filter - Having Trouble with Clamp Ring Knob Assembly

    I posted a few days ago about how I had to order a new clamp ring knob assembly for my filter. I went to install it today, and the instructions state that the gap should be no larger than 1/16". At first it tightened easily, but then it started squeaking really badly. I'm also getting resistance as I try to turn it with the socket wrench. I still have a bit to go, and I'm afraid that I will damage the filter or bolt. Am I doing something wrong? Is it normal for the bolt to make noise when it is being tightened? From what I can see, everything is seated property. I appreciate any suggestions.

    Here is a picture of the filter:

    Inground Pool - 35,000 gallons - SWG (Nature2 - FUSIONSOFT1400) - Cartridge Filter

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Jandy CV460 Cartridge Filter - Having Trouble with Clamp Ring Knob Assembly

    Yep, mine squeaks quite a bit. A fair amount of resistance is good, but don't go crazy. I wish they would publish some torque specs. I use a short ratchet 3/8" and tighten as much as I can without using a lot of leverage.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    Voorhees, NJ
    Posts
    49

    Re: Jandy CV460 Cartridge Filter - Having Trouble with Clamp Ring Knob Assembly

    Quote Originally Posted by pooldv View Post
    Yep, mine squeaks quite a bit. A fair amount of resistance is good, but don't go crazy. I wish they would publish some torque specs. I use a short ratchet 3/8" and tighten as much as I can without using a lot of leverage.
    This is how tight I was able to get it. It's 1/16" in the front part, but the gap is wider toward the back of the filter. Is that normal? Do you think it's sufficient? I see the warning about the filter top blowing off, so I want to make sure I'm careful.

    Inground Pool - 35,000 gallons - SWG (Nature2 - FUSIONSOFT1400) - Cartridge Filter

  4. Back To Top    #4

    Join Date
    Dec 2014
    Location
    Riverside California
    Posts
    473

    Re: Jandy CV460 Cartridge Filter - Having Trouble with Clamp Ring Knob Assembly

    As with any type of band clamp, you need to take a rubber mallet and firmly tap the band all the way around the circumference of the band as you tighten it. This helps to seal the band and you will be surprised how much more you can tighten the band after taping it. As for the squeak, put some type of lubrication on the threads and it should quite down. I like to use silicone spray as it will not attract dirt.

    Hope this helps you!
    38000 Gal, IG, Plaster, 20' x 40' x 10', Attached Raised Spa, Intelliflo VS 3 HP (011018), Pentair Quad DE 60 Filter, Raypak (Rheem) 400,000 BTU (407a low Nox), Easy Touch 8 upgrade, Screenlogic 2 with wireless, IS-4 Spa Side Remote, Stenner 45MPHP10 w/15 gal tank, Intellibrite 5g (3), Dolphin Triton Plus robot with PRO remote, Water Tech Catfish handheld vacuum for spa, TF100 with SpeedStir.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •