Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Polaris 380 issues

  1. Back To Top    #1

    Join Date
    May 2016
    Location
    Howell, NJ
    Posts
    7

    Polaris 380 issues

    Hey everyone - New pool owner here, bought a house with a pool end of last summer. Opened the pool this year to a big green mess and with the help of this forum was able to get it clean and clear. Now I'm working on the Polaris. It's a 380 with booster. It was barely moving and clearly needed work. I spent some time watching videos over and over on how to take them apart and see what's wrong. When I opened it up both belts were completely gone. So I went ahead and replaced those belts and while I was in there replaced all 8 bearings. Took a bit of time as I kept messing up the order of stuff but finally got it back together and it seems to be moving pretty well outside the water.

    I connect it, turn on the booster, and I hold it just under the water to see about the RPM's. The wheel doesn't move at all, it's just stuck. Plenty of water is shooting out of the thrust jet in the back and out the sweep hose.

    Not sure what to do at this point? Should I replace the ball bearing that goes into the drive shaft? That would be part 9-100-1103? It seems to move OK outside of the water so I'm not sure if this is my next move.

    Or could the part that feeds water into the turbine be clogged? How can I test this? I don't notice any holes or tears in any of the tubing, perhaps there is some sand or something stuck where water feeds the turbine?

    Any thoughts for this newbie would be appreciated. I spent a good 4 hours today trying to get this thing fixed and I would kind of like some thoughts before I continue

    Thanks,
    Bill
    30,000 gallon Vinyl IG :: Hayward 4800 DE filter :: Pentair VS 1.5 HP Pump :: Fill w/well water

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,998

    Re: Polaris 380 issues

    I don't have any experience with the Polaris. Here is a how to rebuild a Polaris 280 that might help
    How To Rebuild A Polaris 280 - INYOPools.com


    Also, here, scroll down to Pool Cleaners and there are a bunch for the Polaris
    How to Guides - Swimming Pool Supplies - INYOPools.com
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3
    crusemm's Avatar
    Join Date
    Sep 2011
    Location
    North Texas
    Posts
    31

    Re: Polaris 380 issues

    If the belts are connected, and the wheels are not turning, it may be something is in the turbine. with the gear reductions, it doesn't take much to stop it. I had a piece of a leaf about the size of a nickle get into the turbine area and it stopped mine dead. Try taking the cover off and then applying flow. Also you may have a loose/disconnected hose but not be able to see it. Good luck. P.S. instead of replacing individual pieces, next time may be better off just doing a complete rebuild using a kit http://http://www.amazon.com/dp/B002...35FG88191XGKZF
    21,000 gal In Ground Plaster pool; Nautilus FNS 60 DE filter; WhisperFlo WFE-6 pump; Polaris booster pump and pool cleaner;Rainbow Lifegard HiFlow Chlorine Feeder (not in use); Purex Triton pool light;Hatteras spa light; Intermatic model PF122T Freeze Sentry pump controller; Sta-Rite U-3 Skimmer.

  4. Back To Top    #4

    Join Date
    May 2016
    Location
    Howell, NJ
    Posts
    7

    Re: Polaris 380 issues

    Blew out the lines with air compressor and it's humming along great now. Something was blocking the line that feeds the turbine I guess. Thanks for the suggestions guys!
    30,000 gallon Vinyl IG :: Hayward 4800 DE filter :: Pentair VS 1.5 HP Pump :: Fill w/well water

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •