Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Mastertemp 400 - Burner shuts off, AGS and SERVICE HEATER lights

  1. Back To Top    #1

    Join Date
    May 2016
    Location
    Houston
    Posts
    2

    Mastertemp 400 - Burner shuts off, AGS and SERVICE HEATER lights

    I'm having problems with my 7 year old Mastertemp 400. After much searching I had found a previous thread describing my exact symptoms ,MasterTemp 400 Heater won't stay running, but it was never confirmed if a new control board solved the problem?

    The heater seems to be starting normally when the controller calls for heat. The blower spins up with the HEATING led flashing for 5-10seconds before the burner kicks on. However the instant the burner ignites, the SERVICE HEATER led lights up immediately. The burner continues to fire for 5-10seconds before the burner shuts off. The heater is firing - I can hear the whoosh, feel the exhaust heat up, and readout shows 140-150ish when the SPA ON or POOL ON button is held down. The blower runs its cool down timer and shutoff. I found the AGS led is also lit up on the back of the control board.

    I jumpered across the AGS switch, HLS switch, and water pressure switch but the same thing still happened on multiple start ups. I also followed the trouble shooting guide in the Pentair manual. I pulled the thermal governor (tstat) and verified it opens in hot water. But it was difficult to remove which indicated the internal bypass may have failed. Pulled the header and yes the bypass had failed so thought I had found the problem. Replaced the internal bypass valve and recovered the missing valve & stem piece from downstream piping but still have same symptoms. The inside of the HX tubes, header, and AGS/HLS probes looked clean with no scale or corrosion.
    I don't want to simply start replacing components and hoping for luck or dive into the HX if not necessary so any additional help/comments/insights would be greatly appreciated. Thanks

  2. Back To Top    #2

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,435

    Re: Mastertemp 400 - Burner shuts off, AGS and SERVICE HEATER lights

    If the AGS LED is on but when you jumper the wires for it it still goes on, sounds like the board.
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  3. Back To Top    #3

    In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Location
    Silicon Valley, CA
    Posts
    1,637

    Re: Mastertemp 400 - Burner shuts off, AGS and SERVICE HEATER lights

    I have gotten a few with this problem and it tuned out to be an igniter. While it still worked, it failed to give flame rectification, and would shut the heater down after a few seconds.
    Factory Warranty Station for:
    Jandy/Zodiac, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

  4. Back To Top    #4

    Join Date
    May 2016
    Location
    Houston
    Posts
    2

    Re: Mastertemp 400 - Burner shuts off, AGS and SERVICE HEATER lights

    THANK YOU PS0303! I just installed the new board and that seems to have fixed the problem. Gonna let it run awhile & then cycle it a few times, but looks like it's hot tub time just in time for Memorial Day weekend. Thanks again.

  5. Back To Top    #5

    Join Date
    Mar 2016
    Location
    Chino Hills, CA
    Posts
    185

    Re: Mastertemp 400 - Burner shuts off, AGS and SERVICE HEATER lights

    Hopefully it is happy times now .
    30,000 Gallon Pool IG (Pool 18' X 38' / Spa 7' X 7') - Pentair IC40 SWG - (1) Pentair Intelliflo 2 VST Pump - Pentair DE FNS-Plus 60 Filter - Pentair Mastertemp 400 Heater - Pentair Easytouch 8 - Pentair Electronic valves - Pentair 5G Color LED Pool/Spa Lights - Pebble Sheen Mini Tahoe Blue - Auto Fill/Over Flow - Taylor K-2006C - Completion 3/2016.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •