Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: issue with "step in spa" part of inbound pool

  1. Back To Top    #1

    Join Date
    May 2016
    Location
    toronto ontario
    Posts
    2

    issue with "step in spa" part of inbound pool

    new to this have done a fair bit of research but no expert
    we have a 25 yr old but excellent inground kafka I believe liner pool with a "step in spa" as part of it
    it seats about 4 has its own intake and outbound lines that "mix" at the pump and heater so it can be run as a stand alone or on combo with the pool
    for the last several years have always had issues getting the spa part working as water has tended to come "up" the venturi inlet on the top.....but now the issue isn't stopping
    spa has 2 water collection ports that drain to the pump/heater at the bottom and 4 inlet jets, 3 near the top and one at the same level near the bottom as the water collection ports.
    water will poor out of the venturi hole at the top and i can't close it off...I guess i could try to plug it but it has a threaded pvc tubing that the screw won't close fully..... the only way now to
    prevent water coming OUT the venturi is to remove one of the UPPER jets that screw in completely and essentially allow theatre to come out with "less" pressure.... if i just open the jets or remove the lowest jet, water still comes out the venturi.....
    we aren't "losing" water but Im guessing there is a broken venturi connection ????) are these supposed to act as one way valves ???
    its all ingrained and under concrete and I'm not sure anything is accessible from outside the spa component

    any and all explanations and advice is appreciated

    thanks

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: issue with "step in spa" part of inbound pool

    Sounds like a clog in the lines after the venturi.

    Seen it here before. I think the last guy discovered a chunk of concrete or mortar that some slob got in the pipes when it was built finally worked it's way down.

    Use the search box for "Clogged Venturi" and you'll find lots of older threads about the issue. It saves me a lot of typing.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3

    Join Date
    May 2016
    Location
    toronto ontario
    Posts
    2

    Re: issue with "step in spa" part of inbound pool

    Thank you very much
    im going with the working diagnosis of broken jets or at least jets that don't function as designed.
    I have searched as you suggested and found the jets we have. The ones we have have some cracks and seals are gone so perhaps the issue is as simple and they just don't entrain air via the Venturi pipes anymore so I've ordered four and will replace them. It's a cheap way to start as they were $13 each. If this doesn't work I'll take it from there
    These are the jets

    Waterway Spa Poly Jet 210-6097 Deluxe Scallop Face Roto Gray

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •