Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 11 of 11

Thread: 2.5" pressure guage from tftestkits failed after only 14 months?

  1. Back To Top    #1

    Join Date
    Aug 2013
    Location
    Oklahoma City, OK
    Posts
    125

    2.5" pressure guage from tftestkits failed after only 14 months?

    Not a huge deal but I thought these gauges were supposed to be a little more rugged than this. The gauge is just stuck at 12 psi. Kind of a bummer!
    20000 Gallon, Sand Filter, IG Plaster, Hayward Aqua Rite 40k SWG, TF-100 Test Kit, Taylor SpeedStir

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    Have you contacted them directly about it?

    Was it left on the filter during the winter?

    I leave mine on the entire year and it's 3 years old and still working. Of course our south Alabama winters are nothing like your Okie winters.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Aug 2013
    Location
    Oklahoma City, OK
    Posts
    125

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    I did not contact them on it. I did leave it on the filter but we had a mild winter and I run my pool year round so that should not have been the issue. Like I said not a huge deal I just wondered if anyone else had the same problems as I have had.
    20000 Gallon, Sand Filter, IG Plaster, Hayward Aqua Rite 40k SWG, TF-100 Test Kit, Taylor SpeedStir

  4. Back To Top    #4
    Pool Tool's Avatar
    Join Date
    May 2014
    Location
    Western Chicago Area, IL
    Posts
    754

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    If anything were to freeze it would be gauge probably, even with the pump running there is limited flow there and its readily affected by weather as it protrudes. But unfortunate to say the least, but definitely seems like an exception not the norm.
    16' x 32' (21100 gal), vinyl, 1.5 hp Hayward SuperPump,
    Tagelus TA60/60D Sand Filter, Raypak 399K Digital Heater, TF-100

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    I bet the water froze in the bourdon tube. That's a small flat curled tube and there's no flow in there. Once the water is in there it is more exposed to the freezing temp than most other equipment. I'd contact them anyway, just see what they say.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,084

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    I did not contact them on it.
    Please email to tftestkits@gmail.net. Tell them your name and address and it will be taken care of.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  7. Back To Top    #7
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    Did you try to open up the vent and see if it equalizes?
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  8. Back To Top    #8

    In the Industry
    OTPirate's Avatar
    Join Date
    Oct 2013
    Location
    Creedmoor, NC
    Posts
    993

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    Quote Originally Posted by Tanner M View Post
    Not a huge deal but I thought these gauges were supposed to be a little more rugged than this. The gauge is just stuck at 12 psi. Kind of a bummer!
    I will be glad to send you a new one! If there ever is any problem please email me directly at tftestkits@gmail.com and I will try my best to fix it in a timely and fair manner.

  9. Back To Top    #9

    Join Date
    Aug 2013
    Location
    Oklahoma City, OK
    Posts
    125

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    Like I said it isn't a big deal I was not trying to slam anyone or seem like it is a bad product or anything. It has been great up until a couple days ago. I was just looking for other opinions on if they had any issues like mine. I will send you an email I do appreciate the help.

    - - - Updated - - -

    I did try the vent but it did not work, still stuck in the same place.
    20000 Gallon, Sand Filter, IG Plaster, Hayward Aqua Rite 40k SWG, TF-100 Test Kit, Taylor SpeedStir

  10. Back To Top    #10
    kywildcats's Avatar
    Join Date
    Jul 2015
    Location
    Mayfield, KY
    Posts
    502

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    Quote Originally Posted by duraleigh View Post
    Please email to tftestkits@gmail.net. Tell them your name and address and it will be taken care of.
    Can't beat that!
    Mark
    20'x28' IG, Vinyl, (Sept 2015) 14,900 Gallon, 3'4 to 5'6 deep, SPLAPOOL 1.5 HP, 220v, 2 speed pump, Waterway Carefree 27" 400 LB Sand filter, Digital Nano plus SWG, TF-100 test kit /speed stir. Dolphin Primal x3 robotic cleaner

  11. Back To Top    #11
    Piolin's Avatar
    Join Date
    Sep 2010
    Location
    Miami, FL
    Posts
    604

    Re: 2.5" pressure guage from tftestkits failed after only 14 months?

    Outstanding customer service!!!
    8,400 gal Intex, 3K GPH pump, 16" sand filter, SWG CG-28669, TF100 test kit, speed stir, K-1766 Taylor salt test.

    The corner stone of TFP
    Pool School - Chlorine / CYA Chart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •