Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Aqua Rite 2004 Vintage Not Generating And Odd Readouts

  1. Back To Top    #1
    kenmacboston's Avatar
    Join Date
    Apr 2012
    Location
    Haverhill, MA
    Posts
    30

    Aqua Rite 2004 Vintage Not Generating And Odd Readouts

    Installed this unit in 2004, I am a SWG pioneer. This year the readout is not logical - I received the following results:
    Pool Temp - HOT
    Cell V - 30.6
    Cell Current - 0
    Desired Output - 72P
    Instant salinity - 0
    Product name- AL-4
    Sware Rev - 1.3
    IT DOES NOT GIVE ME A SALT PPM READING

    So I pulled out the boards, cleaned them and put them back.
    New results:
    Pool Temp - 3.5 (I also tried to convert C to F and viceversa with no luck)
    Cell V - 30.6
    Cell Current - 5.1
    Desired Output - 72P
    Instant salinity - 0
    Product name- AL-0 (Yes, this changed???)
    Sware Rev - 1.3
    IT DOES NOT GIVE ME A SALT PPM READING

    I maintain the unit every 3 months, clean it, etc. Recently checked cell and it is operational.
    Do not understand how the readouts could have changed. The readouts were OK last week. I had to add chlorinie (for the first time) to my pool yesterday as chlorine level was 0.0.
    Any thoughts?


    Ken Macumber
    18,000 Gunite, salt system, 250K BTU Hayward Heater, Waterfall, Fiber Optic Perimeter Lighting.
    20 yrs pool veteran

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Aqua Rite 2004 Vintage Not Generating And Odd Readouts

    How old is the cell? Can not possibly be 12 years old can it?

    So you had the cell tested at a pool store as good?

    The AL number change does not really matter: Question about AL-0, AL-1, AL-3 etc Aqua Rite
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Re: Aqua Rite 2004 Vintage Not Generating And Odd Readouts

    In the second set of diagnostics, the 3.5 would be the average salt in metric (grams per litre). The current does not match with the instant salt. With 5.1 amps, the instant salt should be good.

    Try moving the switch to off and checking all diagnostics again. Then turn the unit on and check again 15 seconds after you hear the unit click on (There's a audible click when the cell is energized).

    If the unit is saying Hot for temperature, then the temperature sensor is too hot or it has failed.

  4. Back To Top    #4
    kenmacboston's Avatar
    Join Date
    Apr 2012
    Location
    Haverhill, MA
    Posts
    30

    Re: Aqua Rite 2004 Vintage Not Generating And Odd Readouts

    The 3.5 g/l sounds right. Converts to 3500 PPM. I tried to switch it to PPM using the method in the Aqua rite manual but it did not work. I don't know how it got switched from PPM to metric. Is there a way to "reset" the diagnostic to factory default to see if the unit is still operational? I'll review it again when I get home later today to see if the unit is operating. Thank you.
    Ken Macumber
    18,000 Gunite, salt system, 250K BTU Hayward Heater, Waterfall, Fiber Optic Perimeter Lighting.
    20 yrs pool veteran

  5. Back To Top    #5
    kenmacboston's Avatar
    Join Date
    Apr 2012
    Location
    Haverhill, MA
    Posts
    30

    Re: Aqua Rite 2004 Vintage Not Generating And Odd Readouts

    I tested the unit at the local pool store and it needs to be replaced. Since the unit (T-15) is not working, could that cause the readings to go bad on the control panel. I am going to buy a new T-15 AND changing the current limiter on the control panel. Please let me know if you think I need to buy an entire new unit, or do the above only.
    Ken Macumber
    18,000 Gunite, salt system, 250K BTU Hayward Heater, Waterfall, Fiber Optic Perimeter Lighting.
    20 yrs pool veteran

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •