Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: Pentair Challenger pump problem

  1. Back To Top    #1

    Join Date
    May 2016
    Location
    Perry Georgia
    Posts
    6

    Pentair Challenger pump problem

    Changed my 1hp motor to a 2-speed 1hp motor yesterday. Rebuilt pump (new O-rings/seals) and now the pump will not move water. Filled strainer basket and filter with water but pump will not move any water. Disassembled pump 3 times to verify all was installed correctly and don't see any issues. Only thing I can think of is a slipping shaft on the impeller but I can't get it to slip by hand.

    I would appreciate any suggestions before I replace the pump.

    And yes, the pump is running in high speed when selected. Low speed also works but not trying to prime pump in low speed.

    Ken

  2. Back To Top    #2


    TFP Guide

    cowboycasey's Avatar
    Join Date
    Jul 2013
    Location
    Fletcher, OK
    Posts
    3,346

    Re: Pentair Challenger pump problem

    Welcome to TFP

    Is it sucking air from the strainer lid?
    Pool: Intex 16x32 15000 gal, 2 speed 340042, Pentair CC320 Filter, CircuPool SJ45 Salt System, Intermatic PE653RC; Hot Tub: 650 Gal SWG Megachlor
    links: pool school * Recommended-Levels * SLAM * CYA chart * Test kits * How To Post Pictures * Poolmath * OCLT ** Support your website if we helped you :) **

  3. Back To Top    #3

    Join Date
    May 2016
    Location
    Perry Georgia
    Posts
    6

    Re: Pentair Challenger pump problem

    Quote Originally Posted by cowboycasey View Post
    Welcome to TFP

    Is it sucking air from the strainer lid?

    I was thinking that also this morning. I put the original o-ring back on the lid and no change. I can't hear it sucking air or feel it either. Yesterday morning the pump was working just fine when I shut it off to change the motor. I had some water drippage from the strainer lid but every thing was working fine. New or old o-ring makes no difference.

    I just removed the impeller but everything seems to be just as it was when I took everythinng apart.
    Question, my new motor states CCW rotation. By loooking at the diffuser that should have been the case with the old motor, but the impeller appears to be right hand rotation? I must be looking at something wrong, but are there any right rotation pumps?

  4. Back To Top    #4

    Join Date
    May 2016
    Location
    Perry Georgia
    Posts
    6

    Re: Pentair Challenger pump problem

    Another quick question, is there a way to check if air is getting sucked in somewhere else? If I stick the water hose in the top of strainer it still does not pump water up to the valve,, or does not even completely empty the basket of water.
    In-ground 20700 gal, Pentair challenger pump, 1 HP full rated 2-speed motor, Triton II sand filter, Polaris pool cleaner with booster pump, Aqua Plus controller.

  5. Back To Top    #5

    Re: Pentair Challenger pump problem

    You can use foam style shaving cream to see if air I s getting sucked in at lid or elsewhere. I'd be curious whether the motor rotation direction or any other issues with the new motor. The motor seems to be the variable that changed. Who did you get the motor from? Can they offer support?

  6. Back To Top    #6

    Join Date
    May 2016
    Location
    Perry Georgia
    Posts
    6

    Re: Pentair Challenger pump problem

    Quote Originally Posted by Thinkly View Post
    You can use foam style shaving cream to see if air I s getting sucked in at lid or elsewhere. I'd be curious whether the motor rotation direction or any other issues with the new motor. The motor seems to be the variable that changed. Who did you get the motor from? Can they offer support?
    Yes it seems that the motor is the only variable. Are most pumps CCW rotation (viewed from the shaft end)? Not sure what my original motor was as it is not marked. Guess I could hook up a line and plug it in and see (original was wired for 120, I wired the new motor for 240).

    Bought the new motor from poolcenter.c0m. They offer support, but exactly what would I ask for as far as the motor is concerned, as the motor is working, sounds as if it spins the pump just as fast as the original.

    This is the motor I ordered:

    1 hp Full Rated Motor Square Flange 56Y - 2 SpeedManuf#: ASB2982
    Item#:Z6643
    In-ground 20700 gal, Pentair challenger pump, 1 HP full rated 2-speed motor, Triton II sand filter, Polaris pool cleaner with booster pump, Aqua Plus controller.

  7. Back To Top    #7
    smitty195's Avatar
    Join Date
    Feb 2015
    Location
    Melbourne, Victoria, Australia.
    Posts
    57

    Re: Pentair Challenger pump problem

    You could also use the hose method,,,,,, turn a hose on slowish speed and allow it to run over all the suction side joins,,, including the pump lid and drain plug if you have one,,,,if the air disappears while running over a particular joins you've found the problem. Hope this helps also.

    intex ultra frame round pool 6831g totally hard plumbed with hayward variable speed pump and jandy cs150 cartridge filter... plus a solar heating roof system with a .75 onga pump and 24" sand filter.

  8. Back To Top    #8

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    938

    Re: Pentair Challenger pump problem

    Take the lid off pump, make sure you have water in pot, on high speed turn pump on and if the water is pulled down you have the right rotation. If water doesn't move it has reversed

  9. Back To Top    #9

    Join Date
    May 2016
    Location
    Perry Georgia
    Posts
    6

    Re: Pentair Challenger pump problem

    Quote Originally Posted by kadavis View Post
    Take the lid off pump, make sure you have water in pot, on high speed turn pump on and if the water is pulled down you have the right rotation. If water doesn't move it has reversed

    Did that already and water is pulled down, so pump is turning the correct direction, which makes me feel a little better. It doesn't build any pressure on the filter side, but the water has to be going somewhere, correct? If it is air leak, it has to be at the strainer or 3ft of pipe before the valve, but none of that was disturbed. No water leaks from pump or strainer basket.

    I will try the water trick to see if I can find an air leak.
    In-ground 20700 gal, Pentair challenger pump, 1 HP full rated 2-speed motor, Triton II sand filter, Polaris pool cleaner with booster pump, Aqua Plus controller.

  10. Back To Top    #10

    Join Date
    May 2016
    Location
    Perry Georgia
    Posts
    6

    Re: Pentair Challenger pump problem

    It seems that my problem was caused by my caution to not overtighten the v-band clamp around the pump housing. It was tight enough to not leak water but would suck air around the whole body. Finally figured it out but now I have burned up a shaft seal trying to find the problem.
    In-ground 20700 gal, Pentair challenger pump, 1 HP full rated 2-speed motor, Triton II sand filter, Polaris pool cleaner with booster pump, Aqua Plus controller.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •