Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Pentair Multi-port leak

  1. Back To Top    #1

    Join Date
    Jun 2013
    Location
    Hunt Valley, MD
    Posts
    62

    Pentair Multi-port leak

    My pentair sm2-pp2 multi-port is leaking from the top. I was wondering what I should buy to fix it. I saw on the internet rebuild kits and complete assemblies. From everyone's experience, which one would make more sense.

    Here is a picture of the multi-port.

    Thanks
    -Dimitry
    Attached Images Attached Images
    28000 gallon outdoor in-ground Plaster Pool; 3/4 HP PB4-60 Polaris Pump; Magnetek Century Centurion 2 HP Filter Pump; Pentair FNS Plus 60sq ft DE Filter

  2. Back To Top    #2
    borjis's Avatar
    Join Date
    Aug 2014
    Location
    Pacific NW
    Posts
    2,058

    Re: Pentair Multi-port leak

    possibly a large o-ring if you look up a schematic for this multiport valve. and maybe the spider gasket.

    just make sure you remember the position it was in / how it was bolted on when you remove it.
    16x32 IG Vinyl, 13,000 Gals. Hayward S-244T sand filter, SP2810X15 pump
    (1.5 HP motor) Raypak PR266AEN (266k btu) gas heater. TF-100 Test Kit.
    Dolphin E10 Cleaning Robot.

  3. Back To Top    #3

    Join Date
    Jun 2013
    Location
    Hunt Valley, MD
    Posts
    62

    Re: Pentair Multi-port leak

    28000 gallon outdoor in-ground Plaster Pool; 3/4 HP PB4-60 Polaris Pump; Magnetek Century Centurion 2 HP Filter Pump; Pentair FNS Plus 60sq ft DE Filter

  4. Back To Top    #4

    Join Date
    Jul 2012
    Location
    Dallas, TX
    Posts
    179

    Re: Pentair Multi-port leak

    I have the same Multiport Valve. I had a recent issue with the same Top/Handle area Leak. I ended up replacing this part to fix my leak. The leak was caused by wear/scars on the sealing surface where the Shaft O-Ring's seal against the inner surface of the Top Plate (Pentair P/N 271169).

    Top Plate.jpg

    This thread may help you with your issue. Another member had an issue with the same model valve. I recently did some price comparisons, comparing the individual rebuild parts vs purchasing a new Top Assembly Pentair P/N 270067 . I ended up buying a new Top Assembly so I'll have a quick replacement spare and rebuild the original assembly at my convenience.

    Regarding your 2 links, the internal parts should be the same.
    - Pool Type: 15k Gal Gunite IG non-SWG / Built 1988
    - Pump: Pentair Challenger / Sweep Pump: Letro Model LA01N .75HP Single-speed / 6 hrs-day (1 turnover)
    - D.E. Filter: OEM: Nautilus (Pentair) #NS 36 / 36 Sq Ft / D.E. Charge: 3.6 Lb
    - Pentair 4-wheel Sweep LL505G - Booster Pump runs ~2 hrs/day

  5. Back To Top    #5

    Join Date
    Jun 2013
    Location
    Hunt Valley, MD
    Posts
    62

    Re: Pentair Multi-port leak

    Scoop,

    Thanks for the reply and other thread. It was very helpful. A couple of questions:
    1)How long did it take you to replace the top assembly? Just trying to allocate my time. When you have kids, it is difficult to have a lot of time to work on projects

    2)How did you finally get the spider gasket off?

    Thanks
    -Dimitry
    28000 gallon outdoor in-ground Plaster Pool; 3/4 HP PB4-60 Polaris Pump; Magnetek Century Centurion 2 HP Filter Pump; Pentair FNS Plus 60sq ft DE Filter

  6. Back To Top    #6

    Join Date
    Jul 2012
    Location
    Dallas, TX
    Posts
    179

    Re: Pentair Multi-port leak



    Replacing the complete Top Assembly (Pentair P/N 270067) didn't take long, probably ~10-15 minutes. That assumes you have the complete Top Assembly available to install. A small power driver tool is also great to have handy .

    If it's your first time to replace the part, insure that you install the replacement assembly oriented correctly. On my valve, there's an alignment pin that mates with the Top Assembly.

    Spider Gasket...well.... that's another story *lol* . I went into some detail in the other thread about it. My main issue was twofold:

    - First time replacing the Gasket
    - I was replacing the original Gasket which was completely glued into the entire Gasket Channel.

    That made it a project for me but I ended up using a small Utility Knife to slice out the old Gasket. Mainly, I cut the outer edge of the Gasket from the outer wall of the Gasket Channel.

    I previously tried an online suggestion to use a non-acetone Nail Polish solution to help dissolve and remove the old Gasket material. That procedure wasn't successful for me. I also tried filling the Channel area with the Nail Polish liquid and allow soaking time but that also didn't help much for me.

    The main concern I had was preventing or reducing the amount of Channel scarring as I removed the Gasket. I was unable to prevent some minor damage to the Valve Gasket Channel area but after talking with my pool guy (runs his own store, used him for years for major pool issues), he told me that it was almost impossible to prevent minor scarring in the Channel and it wouldn't affect the Gasket operation (wouldn't create leakby issues).

    I found that to be true with my valve. The pool guy also said that subsequent Gasket replacements would be a lot easier since a lot of the original factory Gaskets are completely glued into the Channel which isn't necessary to keep the Gasket from dislodging from the Channel during proper Valve cycling actions.

    The other issue that concerned me was that I couldn't completely remove all of the old Gasket material from the Channel. I was concerned because I figured that would cause leakby issues.

    I asked my pool guy about this as I was removing the old Gasket and he said "No problem, as long as you remove most of the old material and there's no big portions remaining that would prevent the replacement Gasket to seat into the Channel."

    That turned out to be true for me. I've used the Valve several times since replacing the Gasket last December with no leakby issues having been seen.

    Many Gasket issues arise as a result of the pool owner operating the Valve improperly, ie, attempting to rotate the Valve with the Pump still on.

    Here's my routine, in rotating my Valve:

    - Turn off Pump. Wait about 5 seconds for the pressure to fully equalize while observing the Valve Handle relaxing (slightly moving upward).

    - Rotate to desired position.

    I haven't practiced a common recommendation of rotating the Valve only in one direction, ie, only rotating Clockwise. I don't have any issues with the recommendation . It's that I haven't noticed any issues arising as a result of rotating my Valve direction in both directions.

    Note about Spider Gasket replacement: I allowed a lot of time for that task as it was my 1st time doing that and although I had anticipated difficulty removing the factory-glued-in Gasket, I didn't expect it to be one of those "longer" projects, at least for me .

    I also allowed an overnight "curing" time to allow the new Gasket to bond with the advesive that I used in the installation process. I also wanted to keep the area dry (as recommended in Spider Gasket replacement procedures).

    I used a couple of old t-shirt rags to plug the Valve ports to keep the Gasket Channel area dry after I removed and glued in the new Gasket.

    I also used my lawn leaf/grass Blower to dry out the Channel area and also to remove small pieces of the old Gasket material and glue before applying the new Gasket adhesive.
    - Pool Type: 15k Gal Gunite IG non-SWG / Built 1988
    - Pump: Pentair Challenger / Sweep Pump: Letro Model LA01N .75HP Single-speed / 6 hrs-day (1 turnover)
    - D.E. Filter: OEM: Nautilus (Pentair) #NS 36 / 36 Sq Ft / D.E. Charge: 3.6 Lb
    - Pentair 4-wheel Sweep LL505G - Booster Pump runs ~2 hrs/day

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •