Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Is my Booster pump dead? Polaris 280

  1. Back To Top    #1

    Is my Booster pump dead? Polaris 280

    Opened the pool today and tried to startup up my polaris. As soon as I flipped the switch I saw sparks and then just a hum. It's going into it's 10th season. Is it dead or might it be repairable?
    TF-100 Test kit, 24,000 gal. free form Vinyl. mybluepool AC-600 SWG, STA-RITE S7MD60 DE filter, 3/4 HP STA-RITE MPRA6D pump, Polaris 280 w/booster, Raypack Propane heater, Looplock mesh cover; All located in New England.

  2. Back To Top    #2

    Re: Is my Booster pump dead? Polaris 280

    Ten years old and sparks indicates that repair is unlikely. Probably time for a new one.

  3. Back To Top    #3
    Scotty5x5's Avatar
    Join Date
    May 2016
    Location
    North Richland Hills
    Posts
    1

    Re: Is my Booster pump dead? Polaris 280

    There is nothing electrical in a polaris is there? Probably just your switch. Ten years, you would probably enjoy a new one .
    33,000 gal. in ground fiberglass pool; cartridge filter

  4. Back To Top    #4

    Re: Is my Booster pump dead? Polaris 280

    Quote Originally Posted by Scotty5x5 View Post
    There is nothing electrical in a polaris is there? Probably just your switch. Ten years, you would probably enjoy a new one .
    Actually, the booster pump uses an electric motor to pump the water (it's a pressure side cleaning system).
    TF-100 Test kit, 24,000 gal. free form Vinyl. mybluepool AC-600 SWG, STA-RITE S7MD60 DE filter, 3/4 HP STA-RITE MPRA6D pump, Polaris 280 w/booster, Raypack Propane heater, Looplock mesh cover; All located in New England.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •