Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Jandy Laars LT no power

  1. Back To Top    #1

    Join Date
    May 2016

    Jandy Laars LT no power

    Hoping to get some help on our non-working Jandy Laars LT heater!

    It has been working fine, no issues or signs of trouble; I even keep it (reasonably) clean. We last used it a couple days ago without issue.

    Tonight, I turned on the filter and heater via the remote and noticed the water was still cool some hours later. Walked over to the heater and saw nothing doin -- no blower, no sounds, not even any lights on it. The remote still showed as the heater running. Weird.

    I checked all the breakers -- all on. Turned 'em all off, waited 5 mins, then turned them on -- no dice.

    I pulled the logic board and could not see any obvious burn marks or blown capacitors, etc, but I was using a flashlight so maybe I missed it.

    I didn't have a multimeter at that time, but will have one tomorrow. Anything I should be testing for?

  2. Back To Top    #2

    In the Industry
    ps0303's Avatar
    Join Date
    Jul 2011

    Re: Jandy Laars LT no power

    Sounds like maybe the wire from your controller to heater has an issue since it never received the signal to turn on. Can you put it back to manual mode and operate it OK?

    Look at this book on page 9 for how to operate in manual mode.

    A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts