Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Aqualogic wired keypad stopped working!

  1. Back To Top    #1

    Join Date
    May 2016
    Location
    West Kelowna
    Posts
    1

    Question Aqualogic wired keypad stopped working!

    Hi everyone have the Aqualogic P4 panel and it's about 8 years old now. Last summer I had the blown solder trace on the relay that I fixed myself. This year upon opening my keypad in my house stopped working. It's the AQL2-WW-PS-4

    It lit up and I can use the buttons to turn the lights and pump on, but the display is just lit up, no text on it. So I can't see pool temp ect.

    I opened the panel up and took the connector off that goes onto the cct. board and when I did that one of the wired broke off. I thought YES, that's the problem bad connection. Reconected and tried it again and the panel worked, but only for 30 seconds then it went out again. I've tried tracing the connection from the solder to the wires and that connection seems to be working fine. Any thoughts? I'm at a loss now. Not sure if it's a keypad issue or a control board issue.

    Please help. Here's a picture of the keypad and the circuit board.
    Attached Images Attached Images

  2. Back To Top    #2
    Casey's Avatar
    Join Date
    Apr 2007
    Location
    SW PA
    Posts
    10,157

    Re: Aqualogic wired keypad stopped working!

    So sorry you're having issues. Let's see if someone can help you.

    Welcome to TFP!
    I'd bet you my bikini you'll never get TFP water from a pool store!

    24' Sharkline Venture De Filter

  3. Back To Top    #3
    Scout101's Avatar
    Join Date
    Aug 2015
    Location
    North Kingstown, RI
    Posts
    161

    Re: Aqualogic wired keypad stopped working!

    Following this one, having pretty much same problem. Display lights up, no text, and thus basically no control past on/off. Calling the automation experts!
    IG Vinyl, free-form 25' x 40', 25,000 gal., Hayward 1-1/2 hp Superpump, Hayward S310T 500lb. Sand filter, AquaLogic T-Cell 15 SWG and Automation, Hayward H300 Milivolt 300k btu NG heater, TF-100 Test Kit w/spinner

  4. Back To Top    #4
    Scout101's Avatar
    Join Date
    Aug 2015
    Location
    North Kingstown, RI
    Posts
    161

    Re: Aqualogic wired keypad stopped working!

    Anyone have thoughts on this? Worth spending the $200 (amazon price) to try and replace the local control unit, or more likely to be the circuit board (or both)?
    IG Vinyl, free-form 25' x 40', 25,000 gal., Hayward 1-1/2 hp Superpump, Hayward S310T 500lb. Sand filter, AquaLogic T-Cell 15 SWG and Automation, Hayward H300 Milivolt 300k btu NG heater, TF-100 Test Kit w/spinner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •