Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: High Pressure at Pool Opening

  1. Back To Top    #1

    Join Date
    May 2016
    Location
    OTTAWA, Canada
    Posts
    8

    High Pressure at Pool Opening

    I have a 12 X 27 onground/partially inground pool with a Hayward cartridge filter. Normally a fresh/clean filter starts at about 12.0-12.5 psi and I remove to clean at about 18.5-19.0. After I had my pool opened by my pool supplier crew I had to top up the water level before (a day later) starting it up myself. The discharge pressure started out at 17.5 psi. I was surprised by this since I bought a new filter last season and cleaned it well before storing it for the winter. In any case I decided to clean it with the special filter cleaner solution - immersed it overnight and cleaned out all the pleats with a hose. I didn't get much dirt out, since, as mentioned, I had cleaned it last fall at shutdown. I started up again and I have the same 17.5 psi reading; it's now 18.0 psi after circulating for 4 days. I have checked for air leaks on the suction side and any obvious obstructions or diversions on the discharge side but can't see anything. I hate to buy and try another new filter so soon, but I've run out of troubleshooting ideas.

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: High Pressure at Pool Opening

    Is the flow good? It could be as simple as a bad gauge.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3

    Join Date
    May 2016
    Location
    OTTAWA, Canada
    Posts
    8

    Re: High Pressure at Pool Opening

    Thanks Richard 320, the flow appears fine and the gauge is quite new and went through the full range of pressure while building up and eliminating air at startup. I'll check it out.

  4. Back To Top    #4

    Join Date
    May 2016
    Location
    OTTAWA, Canada
    Posts
    8

    Re: High Pressure at Pool Opening

    I have been troubleshooting my entire discharge/pool return system to see if I can find the source of the highpressure problem. I have an "Aqua Genie" combined skimmer/jet system. I'm wondering if the outlets (jet flows) from the pressure chamber are restricted. There are two rows of jets - only the bottom row has flow and even it may be restricted. I'm going to check with my supplier how it is supposed to be working and if anything could have been done to restrict it in either the closing last fall or the recent opening. In the meantime... maybe someone out there is familiar with the Aqua Genie?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •