Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: skimmer/pump issue

  1. Back To Top    #1

    Join Date
    Apr 2016
    Location
    columbus, ohio
    Posts
    2

    skimmer/pump issue

    I am new here and in the pool world and cant seem to find any information. Any help would be much appreciated.

    I have a brand new aqua genie skimmer. The old one was replaced at the end of last season due to a leak. When the installer put this new one in he also opened an old return line that was previously blocked off/patched. The lone is 18in below the skimmer. We just opened the pool today and cant seem to get water flow when the pump is on. Does the aqua genie even need a separate return? Looking through installation instructions it doesn't seem so but we are lost.

    My installer has been doing this for 15 yrs but never worked with aqua genie so he's not much help. Any ideas? We're ready to have the pool operational again!

    Pool is inground 18x36. This is the only skimmer. Thank you!

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,078

    Re: skimmer/pump issue

    Welcome to the forum.

    There should be no relationship between the flow coming into your pool and the aqua genie (which takes the water out)

    Is your pump priming? (Is the pump strainer basket filling up with water?)
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3

    Join Date
    Apr 2016
    Location
    columbus, ohio
    Posts
    2

    Re: skimmer/pump issue

    Good morning and thank you for the welcome/reply. The aqua genie is actually unique in that it has a built in return. The pump is priming, well partially. It fills part way and then stops then continues that cycle


  4. Back To Top    #4

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,078

    Re: skimmer/pump issue

    The pump is priming, well partially.
    My guess then is that you are sucking air into the system somewhere between the skimmer and the pump. Find where that is, and the problems will stop, I believe
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •