Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: Do I have mustard algae

  1. Back To Top    #1
    Capstone's Avatar
    Join Date
    Jul 2015
    Location
    Alabama
    Posts
    10

    Do I have mustard algae

    I am a first-time pool owner and a little lost right now. I have been testing using the Taylor kit and maintaining the pool using the BBB method. My signature shows that I have am using a SWG; however, I have not added salt to the pool yet, so I have been adding bleach.

    Here is what I know:

    -I initially thought the brown stuff at the bottom of my vinyl pool was dirt. So I vacuumed it.
    -Brown dirt stuff was back the next day in much lower quantity just in the corners of the pool
    -The consistency of this dirt was not really granular like dirt but more "flow-ee". Not sure how else do describe it.
    -About a month ago I started noticing white floating stuff on the pool surface. It is almost like skin. I thought it was coming off a neighbors tree.
    -Thinking that I might have white water mold, I did a SLAM last week. The floaters did not go away.
    -I purchased a sock filter for the skimmer basket two days ago. After running the pump for 12 hours I opened the skimmer to find the sock filters caked with a yellow spongy material.

    See pics below.

    Recent water testing was as follows:

    FC: 4.5 ppm
    pH: 7.4
    CYA: 45 ppm
    TA: 110 ppm

    Is this mustard algae?





    Last edited by Capstone; 04-26-2016 at 06:34 PM. Reason: clarification regarding SWG pool
    40,000 gal vinyl saltwater; Pentair Intellichlor, Pentair Intellibrite 5g; Pentair cartridge filter

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,085

    Re: Do I have mustard algae

    Well, it is not mustard algae

    I see bugs in the bottom picture. nothing you can do about bugs except get them out through the skimmer or, better, get them out of the pool with a leaf net. I have no idea about the yellowish stuff....my best guess is pollen.....it is NOT mustard algae.
    was that a 12 hour collection?

    I am not sure about the white stuff but it is not water mold.

    The dark brown stuff at the bottom of your pool is dead algae

    I think all these conditions will clear up. You can help them do so by elevating your chlorine to around 7 ppm and keeping it there, run the pump 24/7 and keep the skimmers cleaned.....I think everything will pass.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3
    Mod Squad YippeeSkippy's Avatar
    Join Date
    Jan 2012
    Location
    'burbs of Augusta, Georgia
    Posts
    6,491

    Re: Do I have mustard algae

    Looks like pollen to me!
    My Amazon Smile for November12K Fiberglass IG, Infinity 4000 automatic cover, SWCG, Hayward Sand Filter, Hayward 1.5 Pump, Doheny Discovery Robot, Savi Melody LED pool lights, outdoor speakers and other assorted doo-dads. Sundance Altamar Hot Tub.
    Our pool build--> Our Pool Solved Our Sloping Yard Skippy's Cheap Pool Cooler -->Skippy's New Fountain

  4. Back To Top    #4
    smforte's Avatar
    Join Date
    Sep 2013
    Location
    Montgomery,Al
    Posts
    668

    Re: Do I have mustard algae

    Woohoo! Roll Tide....that white stuff is in my pool too. Noticed it about a week ago. It's something floating in the air around our parts. The yellow stuff is pollen...got that too. Now, those bugs....yikes!
    Montgomery, AL
    27000 16 x 36 IG, Vinyl, Grecian, Hayward Sand filter, 1 HP Pentair whisperflo motor, Aqua Genie filter not by choice, no extra jets, Dolphin s300i robotic cleaner,Taylor K 2006 test kit, speed-stir which I couldn't live without!

  5. Back To Top    #5
    Capstone's Avatar
    Join Date
    Jul 2015
    Location
    Alabama
    Posts
    10

    Re: Do I have mustard algae

    First of all, thank you for the quick responses. This forum is incredibly helpful.

    That is a 24-hour run on the sock filter. That is a lot of pollen. I was wondering how I was generating a sponge in my pool.

    The bugs are another issue. The strange thing is that I do not see the bugs in the pool at all. They only show up in the skimmer filter. I have found thousands of them over the last two weeks.

    In addition to the expert responses above, I am reassured that this is pollen based on the testing I did tonight. The test results I posted above were from Saturday. Tonight my results were as follows:

    FC: 2.5ppm
    CC: 0 ppm
    pH: 7.6
    CYA: 40-45 ppm
    TA: 90 ppm

    Thanks all.

    And smforte....Roll Tide. I am originally from Montgomery so I know your area well.
    40,000 gal vinyl saltwater; Pentair Intellichlor, Pentair Intellibrite 5g; Pentair cartridge filter

  6. Back To Top    #6

    Join Date
    Oct 2015
    Location
    Dudley, Ga
    Posts
    22

    Do I have mustard algae

    Do you have any tall grass nearby? I've noticed the same white floating material in my pool and have deducted that it is coming from the super tall wheat-like grass in the field between us and the neighbors. I can get it filtered out and when the wind blows from that direction, it returns. Almost feels gritty when I have felt it in the skimmer sock. I'm in middle Georgia... Roll Tide!


    28k gal rectangular Inground vinyl pool, Pentair IntelliChlor C40 SWG, Pentair SandDollar SD80 filter, Pentair 1.5hp pump with a Pentair 3/4hp booster pump for the KreepyKrauly Legend. Using Taylor K2005 test kit with additional Taylor FAS/DPD kit and following the TFP maintenance method. Pool built 2013, new owner since 11/15. Pool care newbie.
    28,000 gal IG vinyl, sand filter, 1.5 hp pump, sand filter, SWG (Intellichlor), booster pump for Polaris, Well water fill, Pentair control panel

  7. Back To Top    #7

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,085

    Re: Do I have mustard algae

    Tonight my results were as follows:

    FC: 2.5ppm
    CC: 0 ppm
    pH: 7.6
    CYA: 40-45 ppm
    TA: 90 ppm
    Get that FC up to 7 ppm and keep it there until all that junk is gone from you pool.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  8. Back To Top    #8
    borjis's Avatar
    Join Date
    Aug 2014
    Location
    Pacific NW
    Posts
    2,059

    Re: Do I have mustard algae

    LOL "Sponge Maker."

    I had pollen ...BAD 2 weeks ago. Had to vac it out every other day.

    Now there's hardly any. I had my june-july allergies much earlier this year.
    16x32 IG Vinyl, 13,000 Gals. Hayward S-244T sand filter, SP2810X15 pump
    (1.5 HP motor) Raypak PR266AEN (266k btu) gas heater. TF-100 Test Kit.
    Dolphin E10 Cleaning Robot.

  9. Back To Top    #9
    dhldmoore's Avatar
    Join Date
    Apr 2011
    Location
    Montgomery, AL
    Posts
    3

    Re: Do I have mustard algae

    Quote Originally Posted by smforte View Post
    Woohoo! Roll Tide....that white stuff is in my pool too. Noticed it about a week ago. It's something floating in the air around our parts. The yellow stuff is pollen...got that too. Now, those bugs....yikes!
    Roll Tide here as well from another Montgomery pool owner! Just as smforte said, it must be something floating in the air. Only difference I have is that I don't have the little bugs in my skimmer sock as you have.
    26,700 gal - IG 18'x36'-Vinyl Liner, Hayward sand filter, A.O. Smith 1.65 HP Variable Speed Pool Pump Motor, CompuPool CPSC-48 SW Generator, TF-100 w/Speed Stir

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •