Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Broken Pressure Gauge?

  1. Back To Top    #1
    Shirker's Avatar
    Join Date
    Jul 2014
    Location
    Athens, GA - USA
    Posts
    132

    Broken Pressure Gauge?

    I did my opening over the weekend. Finally got the water high enough to turn on the filter. But when I did, the pressure gauge was reading zero. After looking closer, I noticed that the needle is on the wrong side of the gauge. Is this something that can be fixed, or do I need to start looking for a replacement?

    Last edited by Shirker; 04-25-2016 at 10:44 AM. Reason: typo - spelling
    TF-100 | 13.6k gal (24' Round) AG | Chlorine | Sand Filter | Two Speed Motor | Installed June 2014 | Last Opened April 24 2016

  2. Back To Top    #2
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,947

    Re: Broken Pressure Gage?

    You could try a couple sift "love taps" to see if that needle just got stuck or something. Also make sure someone didn't just turn the outer dial to make it look like it's off. If you must replace it, TFTestkits.com has a couple very nice gauges that may work for you at a very affordable price. Hope that helps.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  3. Back To Top    #3
    Shirker's Avatar
    Join Date
    Jul 2014
    Location
    Athens, GA - USA
    Posts
    132

    Re: Broken Pressure Gage?

    Yeah... I have it a few friendly taps with no movement. The return water feels to be close to 4psi which is about where it usually is with a clean filter on low. I guess I will start looking around. Are the sizes pretty standard for sand filters?
    TF-100 | 13.6k gal (24' Round) AG | Chlorine | Sand Filter | Two Speed Motor | Installed June 2014 | Last Opened April 24 2016

  4. Back To Top    #4
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,947

    Re: Broken Pressure Gage?

    Most are fairly standard. Here is the page: TFTestkits.net. You can always verify the size in your owners manual, but I suspect it will work fine.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  5. Back To Top    #5
    Shirker's Avatar
    Join Date
    Jul 2014
    Location
    Athens, GA - USA
    Posts
    132

    Re: Broken Pressure Gage?

    Thanks for the link. Need some fresh test chemicals anyway.
    TF-100 | 13.6k gal (24' Round) AG | Chlorine | Sand Filter | Two Speed Motor | Installed June 2014 | Last Opened April 24 2016

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •