Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Question on leak fixes

  1. Back To Top    #1

    Join Date
    Apr 2016
    Murfreesboro, TN (Middle TN)

    Question on leak fixes

    Now that my water is crystal clear thanks to this helpful forum, on to fix other things.

    I have noticed during my slam I keep losing water, and had hoped it was only due to me removing the cartridge to clean it. But I topped off again yesterday and am down to 1/4 skimmer when I was nearly 2/3 yesterday.

    I can only see 2 clear signs of drips, one from the return as seen here

    And I see some water pooling around the seal on my filter housing

    I ordered new seals for the hayward filter, but what should I do on the return? Should I just replace the entire assembly? Do I need to drain down for that?

    Sent from my SM-G935V using Tapatalk
    26' above ground, 15900 gallons, Cartridge filter Hayward SW1000z4, A.O. Smith Pump SP1515Z1BC 70 GPM, Test kit Taylor K-2006
    Murfreesboro, TN

  2. Back To Top    #2

    TFP Guide
    cowboycasey's Avatar
    Join Date
    Jul 2013
    Fletcher, OK

    Re: Question on leak fixes

    A new seal will probably do wonders for the filter.. On the return/suction it looks like it is all screw fitting where the leak is, you may be able to unscrew everything and use monster tape on the threads 2 PACK- Milrose 70885 Blue Monster 1/2 Blue Teflon Tape: Office Products
    Pool: Intex 16x32 15000 gal, 2 speed 340042, Pentair CC320 Filter, CircuPool SJ45 Salt System, Intermatic PE653RC; Hot Tub: 650 Gal SWG Megachlor
    links: pool school * Recommended-Levels * SLAM * CYA chart * Test kits * How To Post Pictures * Poolmath * OCLT ** Support your website if we helped you :) **

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts