Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick disconnect

  1. Back To Top    #1
    bbrock's Avatar
    Join Date
    Apr 2014
    Location
    Livermore, CA
    Posts
    535

    Oil slick in pool after having used Magic Lube on O-ring for Polaris quick disconnect

    Hi TFPers,
    I recently put some Magic Lube on the O-ring of the quick disconnect for my Polaris 280 hose (part #44 in Polaris 280 Hose Parts; Polaris 280 Pool Cleaner Exploded Parts Diagram

    I did this to make it easier to connect/disconnect the hose from the universal wall fitting. After I did this, I saw a small oil slick on the pool water. Yesterday, I disconnected/reconnected it and again saw a small oil slick. Was this okay to use Magic Lube on this part? Did I contaminate the water? The Magic Lube says it is waterproof, non-toxic, environmentally safe, so I assumed it would be okay. Thanks for any help.

    B
    19k gal IG plaster, built '70s, probably resurfaced in '80s-'90s; Blue Haven Hayward filter C4520BHMB (Filbur FC-1275 cartridges); Hayward MaxFlo sp2302 VSP 1.5hp; 6 solar panels 288. sq. ft. total (142"x47.5" ea.) on 1 story hm; Pentair Compool LX220 Solar Controller; FlowVis flow meter; Maytronics Dolphin S200; AG 300 gal AquaTerra spa; TF-100 & Speedstir; gone: Pentair Challenger 3/4 HP 1 speed; Polaris 280

  2. Back To Top    #2

    Join Date
    Jun 2014
    Location
    Rogers, AR
    Posts
    412

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    I use Magic Lube all the time. A Skum bug in the skimmer is the bomb though. My daughter put a combo of olive and coconut oil in her hair and I came home from work one day and my pool had a really bad oil slick. I popped my Skum bug in and it was gone by the next day.
    16x32 IG rectangular 21,800k new vinyl liner 2014, Triton II TR 50 sand Filter, Pentair 3/4 hsp whisperflow pump, 3 returns, TF100 test kit w/speedstir. Maytronics s 300i robot.

  3. Back To Top    #3
    bbrock's Avatar
    Join Date
    Apr 2014
    Location
    Livermore, CA
    Posts
    535

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    Didn't know there was such a thing. So, are you saying then that it was okay to use Magic Lube on that part that was/is exposed/submerged in pool water?
    19k gal IG plaster, built '70s, probably resurfaced in '80s-'90s; Blue Haven Hayward filter C4520BHMB (Filbur FC-1275 cartridges); Hayward MaxFlo sp2302 VSP 1.5hp; 6 solar panels 288. sq. ft. total (142"x47.5" ea.) on 1 story hm; Pentair Compool LX220 Solar Controller; FlowVis flow meter; Maytronics Dolphin S200; AG 300 gal AquaTerra spa; TF-100 & Speedstir; gone: Pentair Challenger 3/4 HP 1 speed; Polaris 280

  4. Back To Top    #4
    borjis's Avatar
    Join Date
    Aug 2014
    Location
    Pacific NW
    Posts
    2,058

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    Shouldn't hurt anything as its water based.

    interesting item that scum bug, just added to amazon wish list.
    might come in handy some day.
    16x32 IG Vinyl, 13,000 Gals. Hayward S-244T sand filter, SP2810X15 pump
    (1.5 HP motor) Raypak PR266AEN (266k btu) gas heater. TF-100 Test Kit.
    Dolphin E10 Cleaning Robot.

  5. Back To Top    #5

    Join Date
    Jun 2014
    Location
    Rogers, AR
    Posts
    412

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    Quote Originally Posted by borjis View Post
    Shouldn't hurt anything as its water based.

    interesting item that scum bug, just added to amazon wish list.
    might come in handy some day.
    I buy a fresh one every year. Your supposed to leave them in the skimmer all the time but I don't think it is necessary for us. I learned about them on this board and I really like them.
    16x32 IG rectangular 21,800k new vinyl liner 2014, Triton II TR 50 sand Filter, Pentair 3/4 hsp whisperflow pump, 3 returns, TF100 test kit w/speedstir. Maytronics s 300i robot.

  6. Back To Top    #6
    bbrock's Avatar
    Join Date
    Apr 2014
    Location
    Livermore, CA
    Posts
    535

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    Thanks for the replies. And, I too added that Scumbug to my Amazon wish list. Never new about it either.

    The Magic Lube has made it a little easier to connect/disconnect my Polaris Quick Connect at the wall.
    19k gal IG plaster, built '70s, probably resurfaced in '80s-'90s; Blue Haven Hayward filter C4520BHMB (Filbur FC-1275 cartridges); Hayward MaxFlo sp2302 VSP 1.5hp; 6 solar panels 288. sq. ft. total (142"x47.5" ea.) on 1 story hm; Pentair Compool LX220 Solar Controller; FlowVis flow meter; Maytronics Dolphin S200; AG 300 gal AquaTerra spa; TF-100 & Speedstir; gone: Pentair Challenger 3/4 HP 1 speed; Polaris 280

  7. Back To Top    #7
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    I've used the scum balls in my hot tub skimmer. Good for trapping the lotions and oils a bit... and don't look as creepy!

    Also, when lubricating o-rings in general, you don't need to over due it. A very thin coat is all you're looking for. Whenever I do it, I take the o-ring off of it's fitting the wipe it with a paper towel or cloth towel. Then I put on nitrile or latex gloves and put a small dab (pea size or less) on one finger tip. Touch the dab to a few spots on the o-ring then work the o-ring around the whole diameter with my fingers to spread the lube evenly. The o-ring should be glossy but no visible globs or streaks of lubricant.
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

  8. Back To Top    #8
    bbrock's Avatar
    Join Date
    Apr 2014
    Location
    Livermore, CA
    Posts
    535

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    Ok Joel. Tx. Glossy, well after I lubed the o-ring in the quick connect had some it had some definite residual lube. Now I see and hear a little goes a long way ��
    19k gal IG plaster, built '70s, probably resurfaced in '80s-'90s; Blue Haven Hayward filter C4520BHMB (Filbur FC-1275 cartridges); Hayward MaxFlo sp2302 VSP 1.5hp; 6 solar panels 288. sq. ft. total (142"x47.5" ea.) on 1 story hm; Pentair Compool LX220 Solar Controller; FlowVis flow meter; Maytronics Dolphin S200; AG 300 gal AquaTerra spa; TF-100 & Speedstir; gone: Pentair Challenger 3/4 HP 1 speed; Polaris 280

  9. Back To Top    #9
    bbrock's Avatar
    Join Date
    Apr 2014
    Location
    Livermore, CA
    Posts
    535

    Re: Oil slick in pool after having used Magic Lube on O-ring for Polaris quick discon

    Tx again Joel.

    Yesterday, I cleaned my pool filters. I followed your steps to lube the o-ring for my filter housing drain plug, large gasket under the filter housing lid, and also my strainer cover lid. Worked quite well, and only used a small amount. I was not able to remove the o-ring from my strainer cover lid though on my Hayward MaxFlo SP2302 VSP. So, I just used a few small dabs and worked it around the o-ring with it in place. I guess I could have pryed it out with a screwdriver or something, but I didn't want to risk damaging it or the basket lid.
    19k gal IG plaster, built '70s, probably resurfaced in '80s-'90s; Blue Haven Hayward filter C4520BHMB (Filbur FC-1275 cartridges); Hayward MaxFlo sp2302 VSP 1.5hp; 6 solar panels 288. sq. ft. total (142"x47.5" ea.) on 1 story hm; Pentair Compool LX220 Solar Controller; FlowVis flow meter; Maytronics Dolphin S200; AG 300 gal AquaTerra spa; TF-100 & Speedstir; gone: Pentair Challenger 3/4 HP 1 speed; Polaris 280

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •