Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: SWG Check salt and Inspect cell lights iluminated

  1. Back To Top    #1

    Join Date
    Apr 2016
    Location
    social circle, georgia
    Posts
    8

    SWG Check salt and Inspect cell lights iluminated

    Hello,
    i bought house that has pool withan Aquarite Chlorine Generator and Hayward T-Cell15. not sure age of equip. could be 10+ years old
    20,000 gal pool. Water Analysis from Leslies and another pool supply show:
    salt level 2800 and 3325
    my own salt test strips show salt= 3400ppm+-
    ph 7.6 and 7.7 (last check it was 7.4)
    calcium hardness 250+-
    water temp 65F

    preparing for spring in Georgia, Aquarite control panel would poweroff after couple minutes.
    i replaced motherboard and Flow sensor.

    restarted pumps. SWG panel looks good (can check diagnostics).
    Salt level diagnostic goes from --2200 down to -1600.
    after few minutes i get "Check Salt" and "Inspect cell" warning lights.


    I have removed T-Cell and flushed with acid wash (4:1 ratio) two times and flushed with high stream hose.
    ran system overnight 6-8 hrs.

    still get same warning lights.

    don't want to add more salt because water tests show i'm within range

    do i need to run system continuously for longer time or
    is it time for a new hayward T-Cell15


    thanks

  2. Back To Top    #2

    Join Date
    Jun 2011
    Location
    Long Beach, CA
    Posts
    2,669

    Re: SWG Check salt and Inspect cell lights iluminated

    Welcome to TFP!

    Make sure the panel is set for a T-15 cell. Go through the diagnostics to see what cell the system is set for.

    Have you reset the average salt reading? To do this, turn the switch to the Off position and then switch it back to the Auto position. After 5-10 seconds the relay should click and then press the diagnostics button 5 times to display the salt reading and wait for it to settle. Once settled, move the main switch from Auto-Super Chlorinate-Auto and this will reset the salinity level for the panel.

    If this doesn't fix it then there is a bit more to check before we can say if the cell needs replacing.
    16k gal plaster with raised spa, Jandy DEV60 filter, 2 HP 2-speed SHPF Jandy Stealth pump
    Hayward Aqua Rite T-15 SWCG, Jandy LXi 400k BTU NG heater, 350 sq.ft. of Sun Star solar panels, TF-100 Test Kit, Dolphin s300i Cleaner
    Test Kits . Pool Math . Chlorine/CYA Chart . The SLAM Process

  3. Back To Top    #3

    Join Date
    Apr 2016
    Location
    social circle, georgia
    Posts
    8

    Re: SWG Check salt and Inspect cell lights iluminated

    Hello,my control panel displays
    1) default salt level 1700
    when press diagnostics
    1) Pool temp =69
    2) cell voltage=31.6
    3) cell current=0.00
    4)Desired output=59P
    5) instant salinity=-0
    6) supposed to be product name. since i replaced motherboard it just shows: 88 -0


    7) Software revision ? r8.80


    there is no setting for T-Cell type.


    in order to reset the average salt level ...
    i switched to 'Auto'
    display started at -5000 and decremented
    when it reached 3200, i flipped to 'Super Chlorinate' and captured that value.


    My 'desired' salt level is now 3200ppm


    the pump is running
    so far the display is not indicating any warning lights


    update: after an hour or so, the 'Check Salt' light began to flash.
    diagnostics shows instant salinity at 1100ppm


    i had another water sample tested earlier today (by Leslie Pool ), result was 2900 ppm




    2hrs later update:
    salinity standard level now at 2300


    instant salinity registers 1100ppm.
    check cell and check salt lights are on again


    i'll check system out again tomorrow

  4. Back To Top    #4

    Join Date
    Jun 2011
    Location
    Long Beach, CA
    Posts
    2,669

    Re: SWG Check salt and Inspect cell lights iluminated

    Call Leslie's and see if they have a cell tester, most Leslie's do have them.

    This is from the manual:

    Before operation, the Aqua Rite must be configured for the chlorinator cell that will be used. Refer
    to the following information and steps below to set the Turbo cell type.
    "t-3"
    = T-CELL-3, GLX-CELL-3-W
    "t-5"
    = GLX-CELL-5, GLX-CELL-5-W
    "t-9
    = T-CELL-9, GLX-CELL-9-W
    "t-15"
    = T-CELL-15, GLX-CELL-15-W
    1.
    Slide the Main Switch to the "Auto" position.
    2.
    Push the Diagnostic button repeatedly until "t-xx" appears on the display ("t-15" is the factory
    default). If the desired cell type is displayed skip to step 4.
    3.
    To change to a different cell type, slide the Main Switch from "Auto" to "Super Chlorinate" and
    back to "Auto". Repeat this process until the desired cell type is displayed.
    4.
    Push the Diagnostic button to exit

    See if that helps to see the cell in the diagnostics.

    Most likely the cell has worn out and needs to be replaced.
    16k gal plaster with raised spa, Jandy DEV60 filter, 2 HP 2-speed SHPF Jandy Stealth pump
    Hayward Aqua Rite T-15 SWCG, Jandy LXi 400k BTU NG heater, 350 sq.ft. of Sun Star solar panels, TF-100 Test Kit, Dolphin s300i Cleaner
    Test Kits . Pool Math . Chlorine/CYA Chart . The SLAM Process

  5. Back To Top    #5

    Join Date
    Apr 2016
    Location
    social circle, georgia
    Posts
    8

    Re: SWG Check salt and Inspect cell lights iluminated

    my diagnostic only diplays AL-0,1,2,3,4,5
    and the Software revision level r1.4.0

    here is an update.


    I replaced the SL 32 Thermistor on my original mother board and re-installed (removed the aftermarket board i bought)
    everything works appropriately.

    I had the water tested at two different Leslies pool and their salt readings are 2900-3200.

    when i run the diagnostics on SWG controlboard, i get reading of -1200


    I had the Tcell-15 tested and Leslies says its producing chlorine.


    does the Tcell have a sensor that detects the salt level or does the reading come from the 'Flow Control switch" ?which i replaced with brand new switch.


    do i still have an issue with control board?




    thanks
    Gil

  6. Back To Top    #6

    Join Date
    Jul 2015
    Location
    Western NC
    Posts
    115

    Re: SWG Check salt and Inspect cell lights iluminated

    Get a Taylor salt test and find out what your salt level actually is.
    23,000 gallons IG gunite, pebble (I think)
    Hayward SP2610X15 1.5 HP Pump, Hayward sand filter
    Mineral Springs SWCG (it's actually Hayward/Goldline), Hayward Goldline T-CELL-15
    Polaris pool cleaner (with booster pump)
    TF-100, SpeedStir, K-1766 Taylor Salt Test, Lamotte Borate test strips

  7. Back To Top    #7

    Join Date
    Jun 2016
    Location
    Texas
    Posts
    20

    Re: SWG Check salt and Inspect cell lights iluminated

    Does anyone know why the replaced board displays product name 88-0 and software revision r8.80?
    15k gal, IG plaster, cartridge filter, stealth pump, Hayward Aquarite T-15 SWG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •