Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Help with leaking pump

  1. Back To Top    #1

    Join Date
    Jun 2011
    Location
    Toronto, ON
    Posts
    22

    Help with leaking pump

    After this thread Squealing Pump I decided to have the motor rebuilt after closing, installed but couldn't test.

    Opened today and water is leaking at the seal plate, I didn't change anything just reconnected using what was there.

    Sta-rite mpra6e 1 hp could someone tell me the parts I'd need to change to be able to run the pump.

    There is a parts list here http://www.pentairpool.com/pdfs/Dyna...MaxPumpsOM.pdf

    TIA
    18 x 38 IG vinyl modified roman, sand filter, swg, 1hp pump, raypak ng heater

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: Help with leaking pump

    It looks like parts 6, 7, and 10 need replacing when you pull it apart. You'll need some lube for the O-rings, and the directions mention liquid dish soap for the shaft seal #7.
    Not exactly the same, but it should help you visualize things: Pentair Whisperflow seal replacement How-to (w/ photos) A little googling might turn up a video on youtube as well.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3

    Join Date
    Jun 2011
    Location
    Toronto, ON
    Posts
    22

    Re: Help with leaking pump

    Thanks very much Richard.
    18 x 38 IG vinyl modified roman, sand filter, swg, 1hp pump, raypak ng heater

  4. Back To Top    #4

    Join Date
    Jun 2011
    Location
    Toronto, ON
    Posts
    22

    Re: Help with leaking pump

    I replaced the suggested parts now getting a drip from the bottom only when it's running. I tried to take a video but can't upload it here so took a screenshot from the video, I can't tell where it's leaking to know how to stop it.

    Thanks for any help.

    edit took it apart and rechecked my installs small mess up on my part all good to go now.
    18 x 38 IG vinyl modified roman, sand filter, swg, 1hp pump, raypak ng heater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •