Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: New to me pool, yellow algae

  1. Back To Top    #1

    Join Date
    Apr 2016
    Location
    Orlando, FL.
    Posts
    1

    New to me pool, yellow algae

    Hi Everyone,

    Just moved into a house that has a pool (I've never had a pool before). We keep getting this yellow algae. It will go away if you brush it, but comes back in a day or so. The pool company that takes care of the pool told me it might be pollen. Although there is lots of pollen in March/April in Florida I'm not sure that I believe it.

    Thoughts / suggestions?

    Thanks so much for your assistance!


    image.jpg

  2. Back To Top    #2
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,975

    Re: New to me pool, yellow algae

    Hello and welcome to TFP! Very possible you have an algae issue going on. Not necessarily yellow algae, but algae nonetheless. It would be best to have a full set of test results first to validate though. Do you have your own TF-100 or Taylor K-2006 test kit? That will help confirm for us. In the meantime, you may want to read the SLAM link below in my sig. Great to have you with us.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •