Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Honeywell S8600F replacement issues

  1. Back To Top    #1

    Join Date
    Apr 2016
    Location
    San Clemente
    Posts
    3

    Honeywell S8600F replacement issues

    I was having problems with my pool heater so I opened it up and noticed that many of the wires had melted and the ignition control module cover was melted as well. I grabbed my multi meter and tried to find the reason my heater was not coming on but decided I should replace the wire harness and the control module while I was in there (it is 14 years old and melting so why not).

    I ordered a Honeywell S8610U which should be a direct replacement for my S8600F but after replacing all the wires and installing the new control unit I am not getting any spark and the PV light on my control board is not lit. The strange thing is that if I hook up my old S8600F everything works just fine, when I install the S8610U I get nothing. There is no LED status indicator flashing on the new unit, nothing and no PV light on the board. Hook up the old, melted unit and all is well.

    I really would like to replace the old one since I know it will fail sooner or later but cannot get the new one to work...am I missing something?

    Thanks!


    old unit:

    PoolHeaterUnit.jpg

  2. Back To Top    #2
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: Honeywell S8600F replacement issues

    Welcome to TFP,

    Of of the more electrically talented will have to help you, sorry. Good luck on your change out.
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

  3. Back To Top    #3

    Join Date
    Apr 2016
    Location
    San Clemente
    Posts
    3

    Re: Honeywell S8600F replacement issues

    Thanks for the warm welcome and I will look forward to an answer from the forum!

  4. Back To Top    #4

    Join Date
    Apr 2016
    Location
    San Clemente
    Posts
    3

    Re: Honeywell S8600F replacement issues

    Weekend bumpidy bump

  5. Back To Top    #5

    Join Date
    Sep 2013
    Location
    Charleston, SC
    Posts
    535

    Re: Honeywell S8600F replacement issues

    5900 G Fiberglass IG pool (circa 1990), SWG Hayward Aqua Rite GoldLine (2013), IntelliFlo Variable Speed Pump (2013), Hayward Pro Sand Filter (circa 1990), Well water (no iron or other metals fortunately), test with Taylor K2006C, Charleston, SC

  6. Back To Top    #6

    In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Location
    Silicon Valley, CA
    Posts
    1,636

    Re: Honeywell S8600F replacement issues

    When you are replacing one spark box for another (different numbers) the wire lineup may not always be in the same order. Make sure that you are transferring the wires by their name and not the order. If there is any documentation either in the box, or something you can get off the net get it, and read up. Even i must do this as old boxes are more and more becoming replaced by new boxes, and i can confirm that they don't always wire up the same as the old ones.

    MV, MV/PV, and PV should all go to the gas valve. Spark should disappear under the burner tray. Both the 24V should go to either the power on the board or to the x-former.

    Also, maybe most important, confirm that your new box is for the same "kind" of ignition. Either a spark gap ignition, or a hot surface ignition. One wont work on the other, and may ruin parts, ie. the pilot assembly, maybe even your brand new box!
    Factory Warranty Station for:
    Jandy/Zodiac, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •