Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pool pump issues

  1. Back To Top    #1

    Join Date
    Jan 2016
    Liberal kansas

    Pool pump issues

    Okay guys new pool owner here. I am having trouble priming my pump or something I guess.

    Problem when I turn pump onto high it sucks the pump basket dry?

    I turn off pump reprime by removing basket lid till its full then I turn pump on again. Guess what it sucks the basket dry.

    Skimmer basket is clean as well as pump basket. Running mostly 2" pluming but reduced down to 1 1/2" going into pool and Hayward auto chlorinater.

    I can't figure out will not lose prime on low and every time I try and vacuum pool I lose prime.

    Pool as been up for 1 week today
    ABG 18K Gal w/vinyl liner, 24" sand filter w/1.5 hp 2 speed matrix pump/hayward inline chlorinator/ K-2206 tes kit/ build date 3/22/16

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    San Dimas, CA (LA County)

    Re: Pool pump issues

    Low water level or a sticking skimmer flap (weir) are the most common culprits.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts