Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Water level drops when manually priming pump

  1. Back To Top    #1

    Join Date
    Mar 2016
    Location
    Orlando, FL
    Posts
    3

    Water level drops when manually priming pump

    Hi guys. I just recently bought an older house with an underground pool. I've never owned a pool before so my knowledge on service and maintenance is very limited but, I've been reading a lot and watching a lot of videos which has helped. So my issue is that I went to take the filter out to clean it for the first time and I also cleaned the basket right before the pump. I tried using a garden hose to fill the pump and prime it before putting the lid on but, the water level would not fill up. I have a three way valve on the suction side with a drain line connection and a skimmer connection. At first, I thought the water was just going back into the pool or something but then I saw a video of a guy priming a pump for a pool with the same exact setup as me and he filled his pump to the top and it stayed there..

    Possibly related issue here as well. I always have to bleed air out from the top of the filter cartridge every time I start the pump. Is that normal?

    Thanks

  2. Back To Top    #2
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    5,315

    Re: Water level drops when manually priming pump

    What you are experiencing sounds perfectly normal to me. Unless there is a valve, or check-valve, between the pump and the pool, most pumps will drain back into the pool as soon as you open the lid. Just like taking your finger off the end of a straw will let the water out of the bottom of the straw. The question is.. when you put the lid back on and fire up the pump, does the pump prime within a minute or so? If so, then you are good to go.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Calder Spa.

  3. Back To Top    #3
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Water level drops when manually priming pump

    Welcome to TFP!

    If you want to add your pool info to your signature it will help us to help you in the future. More here on that, Pool School - Read This Before You Post
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  4. Back To Top    #4

    Join Date
    Mar 2016
    Location
    Orlando, FL
    Posts
    3

    Re: Water level drops when manually priming pump

    Thanks guys. I will try and add that info

    *one unrelated question I have is that I recently tried using the pool vacuum and I noticed the pressure on the gauge drops to 0. I still see flow going through the jets so it seems like its doing fine but, I wanted to see whether or not this would hurt the pump/motor in any way.

  5. Back To Top    #5
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Water level drops when manually priming pump

    Having the pressure gauge at 0 psi is not a problem. My pressure gauge is always at 0 when my variable speed pump is running at low rpm. As long as water is flowing and the pump sounds "normal" it is fine.

    If I knew more about your pool, pump and equipment I might be able to better help you.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  6. Back To Top    #6

    Join Date
    Mar 2016
    Location
    Orlando, FL
    Posts
    3

    Re: Water level drops when manually priming pump

    I'm at work so I don't know too much info about the pool off the top of my head but it only drops when I hook a pool vacuum with a hose up to the skimmer. I do know my motor is not variable speed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •