Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Liquidator conversion not working

  1. Back To Top    #1

    Join Date
    Jun 2014
    Location
    Casselberry, FL
    Posts
    11

    Liquidator conversion not working

    Hey all...I've had a 4 gallon Liquidator for a little over a year and I finally got around to doing the conversion to 3/8 everything today. I got all my parts delivered and installed everything...had a heck of a time getting the new fittings to fit into the larger PVC holes without them leaking (teflon tape wasn't enough so I added plumbers epoxy around them to seal them up. However, now that nothing is leaking, I can't seem to get any flow going. The "out" connection is sucking air to point where my tubing is compressed, the flow indicator is full of water, but the float is at the bottom. I'm attaching a link to a video I took if it helps...any help would be greatly appreciated.

    https://youtu.be/Rn_vo0cnpbY

    Thanks!
    18-20k gallon in ground pool w/gunite surface
    Leslie's Crystal Clear II DE filter - DE-LE-42054 - 96gpm
    Hayward Super Pump with AO Smith UST1102 1.0HP motor
    Non-SWG

  2. Back To Top    #2
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    9,088

    Re: Liquidator conversion not working

    Sounds like the outlet float is stuck or you have the inlet and outlet reversed. Lifting the outlet float should start flow.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  3. Back To Top    #3

    Join Date
    Jun 2014
    Location
    Casselberry, FL
    Posts
    11

    Re: Liquidator conversion not working

    Quote Originally Posted by JohnT View Post
    Sounds like the outlet float is stuck or you have the inlet and outlet reversed. Lifting the outlet float should start flow.
    Well I've got the tank filled high enough where the outlet float is fully open and the flow indicator itself is filled to the top with water...for whatever reason though it won't flow out of the flow indicator and into the tube.
    18-20k gallon in ground pool w/gunite surface
    Leslie's Crystal Clear II DE filter - DE-LE-42054 - 96gpm
    Hayward Super Pump with AO Smith UST1102 1.0HP motor
    Non-SWG

  4. Back To Top    #4

    Join Date
    Aug 2012
    Location
    Ellington, CT
    Posts
    243

    Re: Liquidator conversion not working

    Looks to me like you got the flow indicator plumbed backwards. Check out page 9 of the Liquidator manual.
    30,000 gal, 20 x 40 ft vinyl, IG, installed 2006
    1 HP WhisperFlo pump, 60 sqft Pentair Quad D.E., Liquidator(8 gallon) with 3/8 upgrade,TigerShark cleaning robot
    TFTestkits TF-100 with SpeedStir,WS
    A proud practitioner of TFP since 2013

  5. Back To Top    #5

    Join Date
    Jun 2014
    Location
    Casselberry, FL
    Posts
    11

    Re: Liquidator conversion not working

    Quote Originally Posted by laprjns View Post
    Looks to me like you got the flow indicator plumbed backwards. Check out page 9 of the Liquidator manual.
    Ugh...that's exactly what it was...everything is working perfectly now...thanks Laprjns!
    18-20k gallon in ground pool w/gunite surface
    Leslie's Crystal Clear II DE filter - DE-LE-42054 - 96gpm
    Hayward Super Pump with AO Smith UST1102 1.0HP motor
    Non-SWG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •