Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Replaced GLX-PCB-MAIN board on Aqua Logic AQL-PS-8, now wireless not working right

  1. Back To Top    #1

    Join Date
    Mar 2016
    Location
    Katy, TX
    Posts
    1

    Replaced GLX-PCB-MAIN board on Aqua Logic AQL-PS-8, now wireless not working right

    Hello,

    I have an 8 year old pool with Hayward equipment including the Goldline Aqua Logic AQL-PS-8 automation system. I just had my second main board (GLX-PCB-MAIN) go out (the clock would not stay set; Goldline customer service said when the clock goes out the only option is to replace the board). The original board laste 5 years, this one just short of 3 years...don't get me started on what I think of the build quality.

    After reading posts about how easy it is to do a DIY board replacement I bought a new one on Amazon and installed it today. It is indeed a simple task all around. However, I now have an issue with the wireless. The system is working fine from the main box control panel. When I try to use either the wireless remote display or the spa side remote, no signal is being received. The display on the wireless remote shows "the base receiver is not responding". However, if I bring the remotes next to the main box and open the door so the display is visible a connection is made. It is as if the wireless signal is very weak, or the antenna outside of the box no longer works. FWIW, I have gone back and verified all connections are correct and are well seated (no issues were found).

    Any ideas? I figure I'll call Goldline on Monday for their thoughts before asking Amazon for an exchange. Any help will be appreciated.

    Thanks in advance,

    Barry

  2. Back To Top    #2
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,490

    Re: Replaced GLX-PCB-MAIN board on Aqua Logic AQL-PS-8, now wireless not working righ

    Sounds like an antenna issue to me as well. Check the wire terminal from the antenna unit and check to see if any of the wires pulled away from the terminal block. This could have happened when you removed it from the board.

    Another check is to remove the antenna connector from the board and see if the "range" is similar to when it is connected. If so, it is probably a bad antenna unit or connector. Could possibly be the new board but the connector is more likely.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  3. Back To Top    #3

    Join Date
    Jun 2010
    Location
    Scottsdale, AZ
    Posts
    11

    Re: Replaced GLX-PCB-MAIN board on Aqua Logic AQL-PS-8, now wireless not working righ

    Hi - any update on the resolution? I'm getting the same issue with by old style GLX-TB.... remote. It just started happening a few months back. I replaced the antenna, but the remote still does not receive communications back from the base unless it's right next to it. The buttons do work from in the house though.
    27k Inground Pool/Spa
    Pebble Tech interior
    Dual 2 hp pumps
    Cartridge Filter
    Salt Cell Chlorinator

  4. Back To Top    #4

    Join Date
    Jun 2010
    Location
    Toronto, ON. Canada
    Posts
    230

    Re: Replaced GLX-PCB-MAIN board on Aqua Logic AQL-PS-8, now wireless not working righ

    Not sure if this will help.

    The 6th button push displays AL-x where x is a number from 0-5. Usually this is zero, but it doesn’t matter what it is, unless it’s attached to a control box made by another manufacturer. This is a programming language setting, so your Aqua Rite knows how to talk to a compatible unit, and allow it to control the Aqua Rite. Your installer will set this, and you shouldn’t change it, unless you change the control box.
    16'x34' Inground Vinyl Pool. 65,500L. Hayward S244T2 24 Sand Filter. Hayward 1hp Super Pump. Raypak PR266 EN 266,000 btu,. AquaRite SWCG. Aqualamp LED 2 w/ remote

  5. Back To Top    #5

    Join Date
    Jun 2016
    Location
    Martinez, CA
    Posts
    207

    Re: Replaced GLX-PCB-MAIN board on Aqua Logic AQL-PS-8, now wireless not working righ

    This guy repairs them at $150 flat rate cost w/ 90 day warranty:

    http://www.bpelectronics.com
    18,000 gunite pool/spa combo. Pebble tec, iaqualink rs8, cl580 filter, aquapure 1400, 400k btu lx heater, 10 solar panels, jandy 1hp, 1 1/2hp, and 2hp stealth pumps for circ, spa, waterfall

  6. Back To Top    #6

    Join Date
    Jul 2016
    Location
    az
    Posts
    1

    Re: Replaced GLX-PCB-MAIN board on Aqua Logic AQL-PS-8, now wireless not working righ

    My GLX-PCB Main board has gone out. I tried to solder on the back of the K1 terminal point, but no fix. I hear it is not that bad to remove and replace but the programing could be an issue.
    I have a wireless remote which has worked fine the entire time ive had the pool. Also I have a variable speed pump as well. Right now Everything works but the salt cell because of the high amps high salt message, so I have just unplugged the cell and will run the pump with chlorine tabs in the pool. Any tips?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •