Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: My polaris 280 is sluggish

  1. Back To Top    #1

    Join Date
    Feb 2016
    Sandersville, ga

    My polaris 280 is sluggish

    Could someone please give me suggestions on my cleaner? It will not climb walls, go to the shallow end and tail will not sweep side to side

  2. Back To Top    #2
    Mod Squad
    Join Date
    Aug 2012
    DFW, TX

    Re: My polaris 280 is sluggish

    Welcome to TFP!

    Did it used to work and now it doesn't? Maybe the filter is clogged. What is the clean pressure on your filter? And what is the pressure now?
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3

    Join Date
    Jul 2014
    Sacramento, CA

    Re: My polaris 280 is sluggish

    What's your water temperature? The hoses definitely stiffen up in the cold; when our water is in the 40s and 50s the tail doesn't sweep and the main hoses feel a lot stiffer. Ours still gets around and does a decent job with the leaf pickup I make him do (that reminds me, it's time to order a new bag), but I wouldn't be surprised if it didn't.
    21000gal IG plaster, Sacramento CA area (late 1950s/early 60s)
    Filter: Cartridge, Pentair CCP420 (2014)
    Main pump: Pentair IntelliFlo VS (2015)
    Boost pump: 3/4hp (2011), Polaris 280 cleaner (unknown age)

  4. Back To Top    #4

    Join Date
    Mar 2015
    Cantonment, FL (Pensacola Area)

    Re: My polaris 280 is sluggish

    I've got a 380 that JUST had a full rebuild kit done last Summer and acting up. On the cleaner itself, after I gave up, local pool store found a small rock in the drive wheel. A little bigger than a grain of sand so not seen, but just big enough to hang the wheel.

    Cleaner still doesn't work right though. One thing I just noticed and you may want to watch is the backup valve ran slow, and even when in use it also wasn't pulling the cleaner back so I have a pressure problem. My filter screen wasn't all that bad, but not good either and my pressure relief valve releasing too much. When looking inside the valve was even cocked a little so more parts on order

    Anyway, I "think" the 280 is so similar it's something else to check. If the backup valve is also not working well then you need to look backwards instead of at the cleaner.
    15,000 Gallons vinyl in-ground screen enclosed, Hayward Eco-star SP3400VSP, Hayward Aqua Logic PL-Plus, Hayward T-15 Salt Cell, Hayward S244T Sand Filter, Polaris 380 with booster pump, Hayward heat pump HP50HA. K-2006 kit.

  5. Back To Top    #5
    wjr75's Avatar
    Join Date
    Jun 2013

    Re: My polaris 280 is sluggish

    I would check the screen that is in the connector that connects to the pool wall. When I first got our pool I didn't even realize there was one in there.
    Inground 22k gallon gunite 15x31 main pool, 15x7 wading pool/sunning deck, hot tub/with overflow (9' octagon with limestone top) & slide NSWG, Aqua Blue Pebble Sheen
    Filter dual cartridge Sta-rite 450sq/ft, TF-100 Test Kit
    Heater Raypak 2100 400k btu cupro-nickel exchanger
    Auto pool cover, Polaris 280 auto pool cleaner, Jandy AqualinkRS8 Remote Control System

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts