Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Pump relay

  1. Back To Top    #1

    Pump relay

    My pump was running non stop. I have a jandy rs4 in do. I replaced the pump relay as the trip lever would not disengaged and the voltage was always 220v. Now the programming from the indoor controller will not operate the pump automatically. Any ideas?


  2. Back To Top    #2

  3. Back To Top    #3

    Re: Pump relay

    It is not in service mode

  4. Back To Top    #4

    Re: Pump relay

    Go through configuration to make sure that everything is properly configured. Pump type etc.

  5. Back To Top    #5

    Join Date
    Dec 2014
    Riverside California

    Re: Pump relay

    Do you hear a clicking sound when you energize the relay?
    38000 Gal, IG, Plaster, 20' x 40' x 10', Attached Raised Spa, Intelliflo VS 3 HP (011018), Pentair Quad DE 60 Filter, Raypak (Rheem) 400,000 BTU (407a low Nox), Easy Touch 8 upgrade, Screenlogic 2 with wireless, IS-4 Spa Side Remote, Stenner 45MPHP10 w/15 gal tank, Intellibrite 5g (3), Dolphin Triton Plus robot with PRO remote, Water Tech Catfish handheld vacuum for spa, TF100 with SpeedStir.

  6. Back To Top    #6

    In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Silicon Valley, CA

    Re: Pump relay

    I'm assuming that you turned the breaker for the motor back on when you were done replacing the relay, yes?
    Factory Warranty Station for:
    Jandy, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

  7. Back To Top    #7

    In the Industry

    Join Date
    Feb 2016

    Re: Pump relay

    Did you hook the wire from the relay to the board where it says filter? (assuming it was your filter pump)

    Did you wire the pump to the line side with the power lines hooked to line too? (that'll cause it to always get power)

    If you have an older RS4 there is a 9v battery hooked to the board to maintain it's memory of schedules and etc when power is cut off from the board... so if that battery is dead you would have to re schedule it.

    If you have power running to it and schedules set and it's in auto and you see the little piece on the bottom of the relay moving in and out while hearing a click... It means you can possibly have a bad board.
    40k Gallon Grecian true L Gunite Pool/Spa. Clean clear plus 520 cartridge. IntelliFlow VS-3050. Polaris booster pump w/ Polaris 360 cleaner. Silencer 1 1/2 hp Blower. Aqualink RS8 w/ Iaqualink 2.0 upgrade kit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts