Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Possible Weak Flow Causes?

  1. Back To Top    #1

    Join Date
    Dec 2014
    Location
    Clayton, CA
    Posts
    22

    Possible Weak Flow Causes?

    I am in need of help in diagnosing the cause of weak water flow. About two months ago I cleaned my filter assembly, after which I noted two things: (1) my flow increased somewhat and (2) the air relief valve pressure indicator on top of the filter went from 20 psi to zero. Since then my flow has been decreasing and it is now quite weak -- to the point where I can no longer effectively vacuum the pool. Suspecting a suction side air leak, I cleaned out the pump basket and re-seated the lid. That did not help -- the flow remained weak. When I restarted the pump, it was unable to push water out of the air relief valve on top of the filter, but water was flowing through the system.

    Is there any reason that this could be caused by something I did wrong in cleaning and reassembling the filter two months ago, or is this definitely a suction side air leak?

    Two other notes that may be relevant:
    1) I have only had this pool for 1.5 years, but during that time I have noticed that the water in the pump basket never stays at the lid even when the flow is good. I have always wondered if this was normal...
    2) When I cleaned out the pump basket, it was actually quite full of leaves and whatnot, yet the air relief valve pressure indicator on top of the filter was still at zero.

    Your thoughts on this topic are greatly appreciated!

    Thanks in Advance,
    -J Phresh
    26K gal, IG Pebble Tec, 2 HP Jandy Pump, 420 sqft filter (Durex Triton C&C Plus with 4 PCC105 Pleatco filters), Barracuda G3 Vacuum, build date unknown, using Taylor K-2006 Test Kit.

  2. Back To Top    #2

    Join Date
    Oct 2015
    Location
    Katy/Texas
    Posts
    411

    Re: Possible Weak Flow Causes?

    It may be that you have debris stuck in the pump impeller. Can you open the pump case to inspect the impeller.
    In ground, 14,000 gallon, white plaster, unheated, stone waterfall, DE Filter, Rainbow 320 Cl, Polaris 3900, FloVis flow meter, F100 test kit, Circupool RJ30+ SWG, Circupool VJ1/Speck Badu EcoM3V variable speed pump.

  3. Back To Top    #3
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Possible Weak Flow Causes?

    Yes, there could be some issue with reassembly. I believe the name of the filter is Purex Triton, now Pentair Clean and Clear. Check here to see if this is it. There are manuals and exploded parts diagrams available here, PENTAIR Cartridge

    More here on finding a suction side leak, Pool School - Suction Side Air Leaks
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  4. Back To Top    #4

    Join Date
    Dec 2014
    Location
    Clayton, CA
    Posts
    22

    Re: Possible Weak Flow Causes?

    Excellent suggestion WASP! As it happens, that was the issue... I checked the impeller and there was all kinds of debris in there. Once I got it cleaned out, the flow went back to normal! The pump was able to easily push water out of the air relief valve on top of the filter, and the pressure indicator on top of the filter now reads 10 psi. Thanks for your help!
    26K gal, IG Pebble Tec, 2 HP Jandy Pump, 420 sqft filter (Durex Triton C&C Plus with 4 PCC105 Pleatco filters), Barracuda G3 Vacuum, build date unknown, using Taylor K-2006 Test Kit.

  5. Back To Top    #5
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Possible Weak Flow Causes?

    Good news! Thanks for the follow up.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  6. Back To Top    #6

    Join Date
    Oct 2015
    Location
    Katy/Texas
    Posts
    411

    Re: Possible Weak Flow Causes?

    Glad we solved your flow problem. Since you found debris in the impeller, carefully check the pump suction basket and make sure there are no cracks. That stuff got past it somehow.
    In ground, 14,000 gallon, white plaster, unheated, stone waterfall, DE Filter, Rainbow 320 Cl, Polaris 3900, FloVis flow meter, F100 test kit, Circupool RJ30+ SWG, Circupool VJ1/Speck Badu EcoM3V variable speed pump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •